Add payment log still not fixed, Unit Treasurer

I can not log payments. I read the previous topic and tried the fixes suggested but it still doesn’t work. I accepted my position as Treasurer again but it didn’t fix the problem. I need to enter payments for the kids before we get too behind.

The payment log bug where treasurers cannot edit is still in development. The workaround is to have an existing unit admin make you a unit admin.

We expect this bug to be fixed in January.

It looks like I am a Troop Admin as well. Is a unit admin different from a troop admin?

@LauraGoodhue - looks like the troop admin and outdoor roles need to be approved by a unit admin.

ok I’ll try to contact them. Thank you.

@Stephen_Hornak’s method will definitely get the position approved. You might be able to re-approve your own admin role. I’m not sure if that works in this context. I know that, in the past, there’s been an issue where unit admin positions have needed to be re-accepted/re-approved. That you could solve yourself by going to My Positions -> Troop Admin, then re-accepting and re-approving the role in the dialog box. However, in those cases, I believe the role looked approved, so I’m not sure if the same solution would also work here.

1 Like

@CharleyHamilton - thank you Charlie… I was fully expecting that I had forgotten something :slight_smile:

1 Like

I’m having a similar issue. I can enter information then when I click save it says “saving” and gets stuck loading. I’ve tried re-approving and re-accepting the unit treasurer role but no dice. Any other suggestions? I even made sure treasurer was my default profile.

Brian,

Are you connected to the Scout with Full Control?

Yes I am. Any other things I may have overlooked?

I am having the same issue. My committee chair has different options than I have and she is able to put in payments. I can enter but I then have the never ending saving circle.

I am finding similar frustrations. Three weeks ago I had access to the troop Payment Logs. Now, I only have access to my child. I am the Troop Treasurer and it is getting very frustrating to not be able to update these accounts. Is there anyone else dealing with this?

Timothy,

The only BSA Member ID I can find for you is not registered. You must be registered as a Committee Member to serve as unit treasurer. I suggest speaking with your unit Key 3 (Scoutmaster, Committee Chair or Charter Org Rep) to make sure you get registered prior to April 12 when all unregistered adults are removed from Scoutbook rosters.

Hello, can you please check my account. I know that I am registered but I do not have access to make changes to the registers. Also please advise if there are any other ways I can get this fixed. Thank you

@TeresaSmith2 Please try re-setting your Pack Admin role:

  1. Go to your Pack Roster page in Scoutbook.
  2. Click on your name.
  3. Click on your Pack Admin role.
  4. Make sure the box is checked next to “Position Approved”.
  5. Click Update.

This should re-set your connection to all Cub Scouts in the pack.

Let us know if this resolves the issue for you.

Hello, I don’t have the option for a position acceted on my Pack Admin Role or Treasurer. I only see I agree to join the unit leader roster. Thank you

@TeresaSmith2 You need to take this path:

My Dashboard → Administration → Pack [your pack number] → Pack Roster → click on your name → click on your Pack Admin role

Make sure that the “Position Approved” box is checked and then click Update.

It does not work if you take a different path through My Account → My Positions

Hi, I checked this and my position does say accepted. I did unclick and reclick it and update though, but it I still cannot add to the pament log

Hi,
Is there anything else that I can try?

Thank you,

Teresa