Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Treasurer unable to add payment logs

Hello,
I am the troop admin for my troop. This problem is in reference to our unit treasurer. He is unable to add records to the Payment Log. He can see the payment log, but if he presses the Add button, he is kicked back to the dashboard. He’s having the same problem in Quick Entry. I tried “unapproving” him and reapproving him, had him clear cache, tried a different machine, none of those worked. Any ideas?
Thank you,
Michelle

Michelle,

Does the treasurer have a full control connection to each Scout? This is required to edit payment log.

Thanks for your reply. I went to connections manager and it looked like he has Full Control for everyone, but I went ahead and selected him to give him Full Control over all just incase.
We’ve had the problem before where we added a new scout and he didn’t have access to Payment Log. So I have needed to do this before for him. However, this time is slightly different as he can get into the Payment Log, but it fails when he presses Add.
I see that he was able to add payments on 1/31/21, so this is a new development.
Regardless, I also sent him a note asking him to try again just incase my mass update to Full Control helped.
Thank you,
Michelle

That’s a good plan. Sometimes Scoutbook needs to have the connections refreshed for things to work properly.

Unfortunately, just heard back that it did not help. :frowning: I’m just at a loss for what to do next.

We can look into this, but in the meantime, you could make your treasurer a unit admin.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.