Add to cart…

I clicked the button and fell into a blackhole. I read the update that says that you just have to purchase items added to the cart. I have no problem doing that, except there’s no purchase button. And yes, I filled out the Captcha.

The announcement from SUAC on the change logs recommended against using it just yet, as there are some issues that still need resolving.

There was also some guidance in the change log post.

1 Like

I’d suggest contacting your council and asking them to submit a ticket with national.


You will need to contact your council on Monday as they will need to open a ticket with BSA IT to fix this.


Thank you! I’ll do that.

There should be a credit card information in the same page with a button to complete purchase. We’ll check this in a mobile device.

I saw it on a computer, but you are using a phone. The programmers are looing into why you don’t see it.

If you are stuck now, ask your council to put in a ticket.

There is a user guide here:

I filled out all the address and cc information above what you can see in the picture. The 2027 that you can see is the expiration year of the cc. There’s no complete button like in the manual. I will try to get on a computer and see if I’m able to complete an order that way, but we’ll reach out to our Council to open a ticket anyways.

@MelissaVallet as a side Note was this all on a Mobile device - just to pass on to developers

Yes, I was signed in on my phone. I do everything on Scoutbook from my phone.

This has been reported to the Scout Shop developers.

3 Likes has their own customer service number if you want to try them:

Let us know how you get this resolved

1 Like

I tried to complete the purchase from a computer and there’s still no “complete” button like in the manual. I called the Scoutshop Customer Service and they directed me to email with a screenshot of the issue.

We’ve contacted our Council to open a ticket with BSA IT as well.

1 Like


How to Take a Screenshot on Any Device | PCMag)%20may%20also%20work.

I posted the picture to show the missing “complete” button. No one here needs a full screenshot.

@MelissaVallet - ah got it… the photos of pc screens usually end up as wavy and sometimes unreadable. I tend to take a clipped screenshot of just the important areas.

We have duplicated the issue. The programmers are working on it. Nothing to do right now but wait.


This may be fixed now

The Saga Continues…

So the Complete button is there and I was able to purchase the items, however I’m still locked out of closing the PO or creating new ones.

Another issue that I noticed was that the Palms in the order was the wrong configuration for the number earned, so I need to cancel the order and order it through my local Council anyways. The Scout earned 7 Palms, but the order was for 1 Bronze, 1 Gold and 1 Silver. When ordering through Council this isn’t a big issue, bc I can always change out one of the pins or add a pin. Anyone using this function won’t be able to fix the error though.