Adding Position for Leader + Button not showing on profile

I have a leader that I need to change his position. On his profile, I am not seeing the add button on the bottom right corner. I see it for all of my other leaders. He’s be with us for over 4 years and has a lot of previous positions listed. Also would Youth Protection training have an effect with this not showing?


Sounds like they are out of ypt or more likely not registered under the BSA # in Scoutbook

@PhilipBailey if you post the BSA # we can give you more information

Thanks. I am thinking their YPT is over due. I’ll check their BSA# for information.


The leaders YPT is up to date and he is an registered scout leader. Any other ideal why it’s not showing. Back in August I was able to change his den leader position.

Does he have a green shield by his name on the roster? Green shield by all of his current positions? Past positions?

I am the pack administrator and for some reason I can’t change him to full access. He had it a couple of months ago. I can update our other leaders but not him for some reason. Also Scoutbook seems to not let me update any of the connections. Hope this helps and thanks.

Does he have a green shield by his name on the roster? Green shield by all of his current positions? Past positions?

What is his bsa member number?

Good afternoon,

He has green shield on all of his positions. Also not seeing the tab for adding new position. All of his accesses are yellow blue circles. Doesn’t let update his status.

His BSA# 13432864


Philip Bailey

Are you trying to do this through Connection Manager? There appears to be a bug there that’s limiting potential permissions settings to View Profile & View Advancement. Discussion is here: Committee Chair can't edit ASM Connections

The Connection Manager bug has just been reported and a potential workaround has been identified. It’s time-consuming (going scout-by-scout from their Scoutname’s Connection’s page), but it will work to reset permissions in a critical situation.

I hand found this work around myself and thought it worked but when I went back to the scouts connections the leader was still marked as view only for both instead of full control.

And you confirmed that the leader in question is on the official roster as a registered leader (with a matching BSA ID) at I ask because that is the other potential pathway that will prevent assigning anything more than View/View permissions.

The add role or position button on the lower right hand corner is not showing. I have tried multiple browsers


Where is the +Add button missing? There are multiple places where you can add a position. Is it missing for all adults or just some? If you post BSA Member IDs (no names) for those without the button we can investigate.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.