Adult applications - lagging

I have adults in two of my units trying to complete online applications (one first time, one a multiple).

For both, they get to a certain point in the process and it just spins and goes no where. Is the application manager down?

  1. Tried 3/14/24 evening - she made it all the way to the checkout screen and it “just kep spinning”.
    ID:14173677 /C10 Council-571 apply to Pack 900

  2. Tried 3/15/24 AM - makes it to the “you are already a registered member. Do you wish to continue” screen. Clicking continue does nothing; it just sits there.
    ID: 13338045/C10 Council - 571 (already a member of P900, applying as multiple to T876)

Well there was a major change to registrations between yesterday and this morning - so maybe try in 12 hours

For the one that’s a multiple, if it is in council, they can log into > my application > transfer/multiple application and click multiple by their name. That should be quicker than the regular app process.

Here is a video that explains the new process and the 3-5 day lag for new adult applications so they can complete the CBC before they become an active leader.

1 Like

This way was not working either. We tried that first and it’s completely blank under the transfer/multiple tab.

The issue is not that they aren’t showing up - it’s that they can’t complete the application process at all.

Make sure they are using the Chrome or Edge browsers.

That they have cleared their browser cache:

And if that fails, have them try a private browsing mode: