Adult Medicals

We used to be able to enter adult medical dates. Not seeing it anymore. Tell me I am not going to have to create (another) spreadsheet… Where did they move it?

It is in the adult’s profile:

I am no longer seeing a profile option at all when clicking on any adult

It looks like your permissions are no longer such that allow you to see “edit profile” as it is between payment log and the positions.

New problem statment. :slight_smile:

ok I’ll play: new problem statement. Everyone in our troop designated a Troop Admin, including myself, has lost this capability in the last 30 days, where we used to have it. How do we get the capability back?

With the functional role of Unit Advancement Chair (designated at my.scouting), you should be able to add the dates for the medical forms at Internet Advancement.


I just looked at the database and you are still listed as a Troop Admin.

@edavignon She also has the Unit Advancement Chair functional role at my.scouting.

@JenniferOlinger In internet advancement I only see the boys on the roster. I can, of course, edit my own profile, but I see no adults on that particular roster. The only rosters where I can see our adults are in scoutbook and in . I used to be able to edit profiles for adults or kids in scoutbook. It seemed like the adult capability dropped off when they moved the scout profiles over to Internet Advancement. What am I missing? Thanks.

yes, I meant even though I am still a Troop Admin, and @ReidHollander who is also having this trouble… we can’t edit adult profiles any longer.

@EstherWingard - you have to change the filter to show adults in IA

ahhh… progress. I now see the adults. and this.

Try logging in at my.scouting, then:

Menu → BSA Web Links → Internet Advancement 2.0

Ok did that, same error.

Try holding down SHIFT and Refreshing the page @EstherWingard

Well I tried that, no luck

Did anyone ask which browser you’re using yet? I know that Safari often has issues, and Edge can be inconsistent based on my tests. I usually have success in Firefox or Chrome.

ETA: Ah, also, have you tried “refreshing” your Unit Admin role in Scoutbook? Go to your positions via:

My Dashboard → Administration → My Units → Unit Roster → your name

select your Unit Admin role, enter it and resave. That resets my admin role when it “breaks” from time to time.

1 Like

good question. I have been trying all recommendations in both Chrome and Safari.

1 Like

I assume you’ve tried multiple people and it’s not just an issue with a single adult’s record.

I second giving this a try