Advancement Report Does Not Reflect All Advancements Entered

I am the Advancement Chair for my BSA Troop, MID: 114191832

I successfully entered 31 merit badges and 1 rank advancement on 11/29/2022 for our 12/12/2022 Court of Honor (COH)
The P.O.'s (part of the problem is that two were generated) do not reflect all awards. Only 11 awards are on the reports. The Advancement Reports have the same problem.
When I attempt to download the Advancement History report for the period from after the last COH until yesterday, it has the wrong data in the PDF - not what was displayed in the report. The report that is generated on the screen has the correct data and shows the advancements were correctly entered.


  • Entered approximately 20 of 31 advancements when the system told me there was a problem. It gave me the choice of going off-line or coming back later. I elected to work off-line. I had done this successfully before; no problems synching.
  • Continued entering awards.
  • Left Internet Advancement, refreshed the Scoutbook screen, then went back to Internet Advancement. I hit the Sync button and the synchronization began. I soon got confirmation the syncing had completed successfully.
  • Generated an Advancement Report and reviewed it. It was missing advancements, so I exited the report by clicking hon the ‘x’ in the upper right corner.
  • I checked some scouts from the Roster and the advancements were all there. I tried to generate the Advancement Report again, but it was still wrong, so I exited it.
  • I logged off and came back to Internet Advancement. Nothing had changed.
  • I went to My Dashboard and checked for P.O.s. It was also incomplete - it matched the Advancement Report I had reviewed.
  • I ran an Audit Report for 11/29/2022 and it showed I had successfully entered and approved all of the advancements. I had never approved the advancements because the report was incorrect. (I am not sure what all of the entries in this report mean, but every award had multiple audit entries.)
  • I ran an Advancement History report to verify the awards were successfully entered. It displayed all of the awards correctly.
  • I cannot update Scout advancement records. I thought I might reset all of the advancement statuses and rerun the Advancement Report. I had used this feature previously to update incorrectly entered dates.
  • I checked the P.O.s again and noticed there were two. One had only 1 advancement and had not been closed, so I closed it.
  • I also checked the Advancement Reports (old), and the report corresponding to the above P.O. was there and had the same data - 1 advancement.

@LeslieKelley First please do not personal Information online - Like full names for scouts.

First thing I would suggest is to go to Scoutbook > needs purchasing report > Open the Closed PO’s > Delete the appropriate ones and make a new PO

Thanks for the reminder about full names. I was focused on debugging the problem.

Thank you. I deleted the two POs, but the “Needs Purchasing” now shows only the 11 advancements from those POs (which would result in one PO, which is good), not the 31 items that need purchasing. This does not entirely solve my problem.

Were some of the items marked as “Awarded”?

1 Like

Yes, there was one. It is the one that had its own P.O. I never ran a Needs Awarding report, so I don’t know why it is marked Awarded.

@LeslieKelley I can setup a screenshare if you want to see it and clean it up

Sure, I would be glad to watch. Thanks.

@LeslieKelley I will send you a direct message > look at top right Avatar to find it > it will be a green dot with a number 1 > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

@LeslieKelley link to screenshare sent in the Direct Message

I turned off pop-up blocking and tried an incognito window. Nothing worked. Chrome is not notifying me that it is blocking pop-ups for the update merit badges operation.

I tried to edit the Advancement Report, but it does not allow me to enter new advancements.

How can I manually add items to the Advancement Report? My council Scout Shop requires a complete report so it can fulfill the order for awards.

Write them in with pencil - just tell them there is a BSA IT issue

1 Like

@LeslieKelley - in my council we are required to provide advancement via hand chisled granite tablets ferried upriver on reed bardges or it fies not count. They have offered a smoke signal alternative but that has been hit or miss :slight_smile:

POSTING HERE FOR ALL: @LeslieKelley I recalled how to change dates of items in IA and it is stupid! Go to Roster > Click History > Select Item and then you can change it there. Just yelled at developer again over it.

1 Like

Thanks, Donovan. I tried it and it only showed three items, which are ones I don’t have any problems with. I tried clicking on one, just to see what came up, and it gave me a system error. I will try again tomorrow.


Try a Shift Refresh again

OK. Now I can get to the merit badges, but I still cannot edit them. If it was a pop-up problem, Chrome would give me the opportunity to allow pop-ups on the site, plus I added the site in my Settings already.