Rank Advancements Reappearing on Advancement Report

I am new to my position as Advancement Chair and still learning how things work.

I am confused since I have had several instances where the advancement reports have altered themselves after I generated them.

Here’s the steps.

  1. I generate a report, which has 13 advancement rows. I print it as a pdf.

  2. The next day, I see there are new items ready for a new report. When I look at these items, it sometimes includes a row that I know was already in the previous day’s report, and I can verify that by checking my previous day’s .pdf.

  3. If I go to check that previous day’s report in the list of generated reports on Internet Advancement, it now has 12 rows only. One advancement is missing from it, compared to the pdf from the previous day that should be identical. It’s the one that’s now shown up again ready for the next report.

This has happened to me several times, and on one occasion, the same advancement slipped to the next report, and then the next report again.

To avoid purchasing unneeded items, I have to always check my reports for duplicates before going to the scout shop.

Is this a known issue? Is there a way to fix this?

Not sure why you think you need a report. What are the 13 rows? or what exactly are the settings of the report you are generating

I am not sure of the settings, just defaults. I leave “show estimated price” slider on.

I have the report to take to the scout shop, which they use. It is required according to the site, see attached.

well at scoutbook.scouting.org > under Reports > you should see Needs Purchasing > if you have 2 old closed Purchase orders with the same item for the same scout you can tell us the PO #s and we can look at it

It is PO #: 805831. If you look at this report now, you will see 12 advancements listed. However, on the report that I printed out when I generated that report I have 13 advancements listed. The one that went missing from the PO is back to the “Need Purchasing” section now. It is the advancement to Star Rank completed on 5/1/2023 by the scout initial H.V.
I took the report that already has her advancement on to the scout shop and purchased the advancement related items before it went back to “Need Purchasing”.
Could you please let me know if you find the reason to why it went back to “Need purchasing”?
Thank you.

Hi Donovan,

I found an even worse example.
On PO 799320, I have scout R.C. with second class rank (4/17/2023), scout S.A. with first class rank (4/17/2023), and scout Y.M. with second class rank (4/3/2023) on my report that I have a pdf of. [On that pdf, scout Y.M. ALSO has first class rank, but that one isn’t a problem.]

Then on PO 800731, all those scouts ranks appear again (except for Y.M.'s first class rank).

Then on PO 801723, the ranks for R.C and S.A. appear again for the third time.

If you have a private way for me to send you these pdfs, please let me know. These pdfs printed at the time the report is done do not match scoutbook’s current “copy” of these same reports, which is the problem since scoutbook seems to have updated itself after creating the report for some reason.

To be clear, you’ve had three POs since 4/17/23. Are you doing weekly shopping?

@AyaSevern - after being purchased are you marking items as awarded when presented to the scout.

@AyaSevern are you the one shopping? Could another user have gone shopping and the items where not in stock so they came back and modified the POs?


In this particular case, the PO No. 800731 and 801723 were only generated so that I can get the advancements that I have already purchased the items for are out of the “need to be purchase” section, so that I won’t get confused in the future and buy extra sets of items for those when I go to the store next time.
I didn’t use those POs.


I have never done that. Am I supposed to do that to every advancement and MB?
I tried to see how to do that and selected my daughter and went to record advancement to see if I can change the status to “Awarded” but her current rank which she got advanced to last month won’t show on the advancement item, so I cannot select it and record it as “Awarded”.


I am sure that I am the only one doing the shopping for our troop. I was able to purchase everything with PO No. 799320 which I have 11 advancements on my copy.

The PO No. 800731 and 801723 were only generated so that I can get the advancements that I have already purchased the items for are out of the “need to be purchase” section, so that I won’t get confused in the future and buy extra sets of items for those when I go to the store next time.

I didn’t use those POs.

I have purchased everything on the last PO that I have generated which is PO No. 805831 and gave a copy of the PO with 13 items to the scout shop. However, now the PO is saved on the Internet Advancement as only having 12 items and one of the advancement is back to the “Need to purchase” section. I did nothing other than generating the report, printing it out and taking it to the scout shop. I didn’t do anything to the advancement that disappeared from the original list.

I just wanted to know why this happens since it has happened to me more than once in the past month.

I have the copies of all the POs which I have generated which shows the same advancement on different POs if I can send them to you privately.

@AyaSevern - here is my process that i have used for a decade.

In scoutbook

  1. Check for items in needs approval… approve them
  2. In needs purchasing- add items to a PO
    3 print out the advancement report
  3. Purchase items at scout shop
  4. Close the PO
  5. Present items
  6. Mark as awarded

If you dont mark as awarded they will hang out until marked as awarded. ALWAYS mark items as awarded when the scout receives them


Thank you for your reply.
I am still learning how Internet Advancement works and not sure how to Close a PO.
Also, I looked at it again but still cannot figure out how to mark advancements as awarded.
Do I go to “record progress” and “record advancement”?
If I do, I cannot chose the rank that the scout just achieved to mark it as awarded.
I can only see the previous ranks and next ranks, not the current rank.

Please go to scoutbook.scouting.org to use the steps i noted @AyaSevern

I’m having this exact issue. Ranks that I know have been purchased are reappearing in my Needs Purchasing Report. I have been adding them back into the appropriate PO, sometimes multiple times, but I have one Star Rank that was purchased by itself, so the PO is showing 0 items now. It wouldn’t allow me to reopen it, so I created a new PO and closed it. It’s happened again though. Our COH is this weekend, so haven’t been able to mark them as Awarded yet.

Original PO is 785975.

You can mark the individual Ranks as Awarded through the individual Scout’s Advancement profile by going into their rank or multiple Awards as Awarded through the Needs Awarding Report.

You’re not crazy though. This is an actual bug that’s happening.


Thank you so much for your reply! I was so happy that you told me that I am not crazy!
When I got the position, all I was taught was what I should be doing on IA. It seems like the person who previous was doing the task has never used the Scoutbook part either and when I finally looked at Scoutbook, there were 654 items in the “needs awarding” section. When I tried to look at the past POs to check these items were on the PO, I discovered that some of the POs are saved with 0 items on them. However, when I asked for the POs which the previous person saved separately, the same POs will have items on them. The POs saved on Scoutbook are unreliable.

I appreciate someone’s response that the reoccurrence of the rank advancement is due to me not awarding the items, but this is not going to solve the problem unless I mark advancements as awarded even though I haven’t actually awarded them. The advancements come back on the next day, so it is not possible that the items will get actually awarded to the scouts that quickly.

I went to the local council office and talked to a lady there and she told me to send the different POs with the same advancements on them so that she could contact National about it, so I emailed her those, but I haven’t heard anything back. I was going to give up and continue to generate the advancement until it won’t appear again. I hope they will fix this since it is very confusing.

Anyway, I was so happy to hear that someone else is experiencing the same thing, since I was sure that I shouldn’t be the only one!

@DonovanMcNeil @jacobfetzer Not sure if you saw my message above. I think Aya wasn’t able to explain the problem clearly, but this is an issue with items that have already been purchased coming off of a closed po and returning to the Needs Purchasing Report. I’ve had several instances this week. Seems to only be Rank Advancements and not any other awards. Let me know if you need screenshots.

You’re welcome! lol

The only time an item “should” reappear on your Needs Purchasing Report is if you’ve deleted an item or a PO.

If you go into the Needs Purchasing Report, you can reopen the PO that the item(s) were on and it’ll ask you if you want to add the items to the open PO. That’s what I’ve been doing, until I ran into the single item issue. After doing this a few times, they seem to be staying put.

I do everything through Scoutbook, through the Needs Approval, Needs Purchasing and Needs Awarding Reports. Your Needs Purchasing Reports area is where you can close and reopen POs, print out Advancement Reports, etc…all in one spot. I have never heard of doing it through IA. Seems like it would be a lot more difficult.