API access error for Scout

I created campout and service activities for my scouts to join. Some can, but at least 2 have received the API access error. How do scouts fix that? TIA!

PS - the previous threads I found about this error seemed to be all related to leader access. If I missed on about Scout access, please point me in the right direction.

I do not understand - you made a Camping log in the past for Scouts to enter themself and record?

I created activities they can join. When they try to join the activity, it gives them this error. But some scouts can and have successfully joined the activity.
activities

Well more info would be needed to figure it out. what is BSA # of a scout that could, and what is BSA # of a scout that could not

could - 130797919 & 132077217
could not - 134812096 & 13658661

could not - 134812096 & 13658661

These 2 do not have accounts under these numbers to log in

They are on our troop roster in IA (that’s where I copied their BSA IDs from) and the screen shot in the first post is from *8661. So what does that mean and how do we correct it?

perhaps the parent is signed in under the parent account? Only a parent can give access to the systems.

So the scout’s account is the one that needs to join the event? A parent can’t do it for them? (Just want to be clear when I explain it to them.)

I have never tried from just a parent account so cannot answer. Also not sure why you are doing it that way, honestly more work for you to slowly have to approve each one when the scouts individually enter it.

Yeah, I have to agree, not to be mean, “you’re doing it wrong”. The way you are doing it makes sense, but doesn’t seem to be the standard or usual approach. I’d recommend that if you are going in, just add all that attended that activity. We do it by looking up who was marked as “attended”. One person to “feel the pain” instead of a dozen or more.

I wasn’t aware there was a right or wrong way to use a built-in feature (“joining an event”) to the tool. Our approach is simply that it’s the scouts responsibility to document their own camp nights and service hours. We do try to make it easier by creating a group event for them to join, but ultimately the documentation is their responsibility. If this is indeed the “wrong way” to do it, then why is the ability to do it in the tool?

The tool is fragile and seems to have some “dead ends”. Our unit discussed having the Scouts do it, but since it is more fragile than ideal and that it would take an adult maybe an extra 60 seconds, we enter it for them. In the future, when the tool is more mature, we would love to go back and correct it.

For Scout involvement we have them print their own permission slips and have the Scribe take attendance. Based on that attendance, we go in and make the entries here.

@AudreyReed your way is perfectly valid and logical - I was just saying I would not want to approve 20 individual entries for each event - as opposed to one person entering them all already approved

1 Like

@DonovanMcNeil That response was directed at @Matt.Johnson’s comment that I was “doing it wrong”. Apologies if my message didn’t come across as intended.

I will say this - he’s not wrong that the system is “fragile” with lots of “dead ends”, and I seem to be developing an unfortunate skill of finding those, especially this week, so my frustration level is high. I don’t think a system that Scouts and leaders rely on should be able to legitimately be described as “fragile” or cost our leaders more time dealing with the system than working with/for the Scouts themselves.

I didn’t mean to “shame you” on doing it wrong. It just seems like they made some assumptions when designed or when tested that make one way work and others not so well.

I agree it should be robust and clear.

Update - I confirmed that both of the scouts having issues were indeed going through parent accounts. These were 2 of our younger scouts that hadn’t set up their own access. Good news is this was finally what encouraged the parents to get independent access setup for their scouts. Woo hoo! Thank you for the help!