BOY SCOUTS OF AMERICA

Scouting Forums

Scout account access not showing link to troop records, etc

We set up a scout account for a few of our scouts to test the scout’s email, access to records etc. It worked fine two days ago, now scouts can login to scoutbook, but cannot see anything related to their troop. Just their own profile and standard scoutbook options, ie forum etc. no progress or troop affiliation. The only change from two days ago was putting them in patrols. Any suggested fixes?

that is working as designed - a Scout’s access is for themself - if they go to My Advancement they can use the breadcrumbs at top of page to navigate to Troop

45

Bump, not the issue, they have no access to anything related to advancements, etc. just plain vanilla scoutbook pages anyone who creates an account.

no - if a scout logs in through their account - they can access their own advancement, logs, calendar, leadership, even message the unit

Or maybe I don’t understand the question @ScottKing3

you are correct two days ago, they had that access. now they don’t. bump

@ScottKing3 - could the scout post screen shots of what they see. I suspect that they may see administration as the first item then the forums and other general links. If the click on administration what do they see.

I have access to his login, been using Scoutbook as a troop admin for 5 years. When I say the menu is not showing up. It is not showing up. If you aren’t having this problem, please do not respond as this is not a user not knowing how to navigate scoutbook. Thanks

ok @ScottKing3 can I setup a screenshare so I can see it so if there is something to report to DEV I can get that done

@ScottKing3 - ok…that was completely uncalled for and darned rude.



5 years of dealing with snowflakes

what about membership? is it approved? I am trying to duplicate this and have not been able to yet

OH - its not connected to a parent? How did you make this scout?

There you go, see below. It is likely a bug created when the scouts were put in patrols.

it is connected to parent (at least it was two days ago), we relinked again after problem started but same screen. So when the patrol was created, the problem started or there has been a different global issue as it happened with all the scouts who set up the account after the patrol changes were done, not an isolated event.

log in as you and look at the scout - see if parents are listed

I still think a screenshare would be simplest

see below, like I said it was working correctly for all scouts who initially set up accounts with parent, verification codes entered etc.

all parent connections are in place on troop account

and under your account the memberships look good and are approved?

  1. Yes
  2. Put into Patrols
  3. No parents had already set up accounts for scouts before patrol move into patrols, Scouts all had access with their logins before being put into patrols.
  4. Yes before and after patrol move, but no access to records after patrol move.
  5. No they were put in patrols after their individual accounts were set up
  6. Correct on this point, with the exception that the accounts for the scouts tested were added before the patrol move in, emails still worked with parents after the move into patrols, but no longer showed advancements, or any affiliation with troop from their accounts, troop account is fine

All BSA# are there and correct