BOY SCOUTS OF AMERICA

Scouting Forums

Be A Scout pin management - not working?

The management portal for the Be A Scout page does not appear to be working anymore. Every attempt to load the page gives a session timeout error - no option to login. I’ve tried while logged into my.scouting.org, and logged out - same thing. Anyone else seeing the same thing?

Mine loaded - took maybe 4-5 secs

Doesn’t matter how long I wait, it never shows. There is no way to go to a login page or anything. I take the “ErrorpageSessionTimeout.aspx” off the URL, and it refreashes directly to that page again. Poor and frustrating design when I can take no actions to remedy the problem.

https://beascoutpinmanagement.scouting.org/UnitPin_Management.aspx?USERNAME

Try a direct URL - replace USERname with your MYST user name

Also try it is a PRIVATE window maybe

Nope. I tried it on a different browser with a fully wiped history and cookie storage. Tried on a mobile phone (LTE, not WiFi). Tried with a private window. Tried on Chrome and Opera. Nothing works.

OK. It would appear that the link has now changes to http://beascoutlink.scouting.org/pages/BeAScoutlink.aspx which now works.

I am unable to get to the pin management system, even with the updated link above. I’m getting the session expired message. I need to fix this soon. Our unit meeting location has changed.

@ChadLarson - I just launched an independent browser window and was able to access both pin management for our pack and troop. I suggest launching a different browser than what are using for scoutbook and see if that helps.

This is a very insecure site. I just logged in directly, and I have access to management screens! grrr. Try to go to the above link. In light grey in the upper right of the screen will be “Sign In”. Use your my.scouting.org login. Once you have logged in, http://beascoutlink.scouting.org/pages/BeAScoutlink.aspx should work to take you to pin placement.

I am also getting the “User session has expired.” error message. I opened one of the links here in an Incognito Window and was also able to get into the Sharepoint back end. While I can see things, I don’t have permissions to make any changes. However, I too found the list of users, and there were only about 15-20 people:

image.

I see a user there that’s likely you, based on the name, and I see my account listed as well. I don’t know why/how we got accounts here. Both of ours said they were created in the fall of 2018. However, I’m wondering if us having accounts here is causing us to have issues.

I tried your tip to log into first and then go to that link, but it doesn’t work. I do get a different error though: “There are no units for this user or the unit where the user is a member is not supported by the BeAScout program.”. I was able to manage our pin just a few months ago, so I don’t know why this is happening now.

I’m still waiting on my position change, den leader to cubmaster, application to be processed, so I wasn’t going to reach out to support until after that, but either way something goofy is going on.

You need to use an Incognito window in Chrome or a Private window in Firefox. It may be called something else in Safari or Internet Advancement. This will bypass the timeout window.

On the BeAScout pin page, you first need to change a setting from Council to Unit to be able to make any other changes.

Neither worked for me sadly.