Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Can't get into Scoutbook

With the update to the new single platform, I cannot get into Scoutbook. I log in to the new domain using my my.scouting single log in. It takes me to my troop’s Internet advancement where everything seems fully functional (I am the scoutmaster). However, when I click on the link in the left navigation bar for Scoutbook, it takes me to scoutbook, which asks me to log in. However, it says “unable to process. Refresh and try again”. I’m hoping this is due to the roll out being today, but wanted to report it.

Thanks!

4 Likes

Hi,

I was having the same problem. Even when I typed in the new Scoutbook URL (scoutbook.scouting.org), I was immediately redirected to Internet Advancement. I don’t understand the reasoning behind the new change, but the transition has severely impacted the user usability. I hope they add a link on their help page to help address this problem for others that may come across this problem and/or look into issue on the Scoutbook and Internet Advancement side.

Here are 2 solutions that works so far:
Solution 1:

  • Clear the history and cookies from your web browser

Solution 2:

  1. Open up a New Private window or an Incognito window
  2. Type in scoutbook.scouting.org into the URL field. It should take you to the regular Scoutbook Information page
  3. Sign in with your credentials

Hopes this helps!

4 Likes

thank you, solution 1 worked for me.

1 Like

I am trying not to be critical but you have got to get this working. Please begin testing your changes prior to deployment. Choose a small group of willing testers and then begin your rollout with them. Scoutbook is a production system and a lot of people depend on it to work. After your latest change I am unable to log in.

9 Likes

We tested it. It worked in QA. URL changes are tricky to reproduce though, since they are slightly different in the QA environment.

That said, I’m also disappointed the redirects don’t seem to be working perfectly. Clearing cache worked for me.

1 Like

Now that it has switched I have issues with scouts who transferred in this year and now don’t have access. Our registrar fixed it once now it’s broke again. Also have one scout who have always had access to but now it says his ID number is in a different unit. Also this was a bad day to switch as most of the US meets on Mondays!

2 Likes

Thanks Jacob. Clearing Cache seems to work. A banner on the login page may be helpful to users today.

Rick Haynes
336-413-3247 cell/text

1 Like

this new system literally sucks, change it back to scoutbook only. thanks

5 Likes

it also would have been nice to have a heads up this was happening and some training on how it works

2 Likes

There was a banner message in Scoutbook for the past several days. The expectation was users would not have to clear their cache. This was supposed to be a seamless change. Obviously something did not work as expected. We are already communicating with BSA IT to try and get the issues fixed ASAP

2 Likes

I’m having the exact same issue. I have tried on my laptop and mobile phone and getting the same error message. We have Scouts who use Scoutbook to enter their own notes and check off requirements. This is another obstacle for them to now overcome, as well as our Adult Leaders who are trying to become comfortable with working online.

This is a HUGE hindrance and causes many of our leaders to give up!

4 Likes

To get around the current issue, you can try clearing your browser cache or using an incognito or private window which starts with an empty cache.

I use the Scoutbook app on my android phone. I haven’t been able to log in. It says “login in failed”. With the updated is the app still operable?

@MarkOsbun - to clarify, there is no scoutbook android app. You may well be using a shortcut on home. Please delete that, clear the browser cache and cookies, then use scoutbook.scouting.org and click on login and create a new shortcut. This worked for me flawlessly.

Mark,

Are you using the Scouting App or accessing Scoutbook from a web browser? I just tested the Scouting App on my iPhone and it is working as expected.

The same issues. can’t log in to Scoutbokk from Advancements.

I’ve tried clearing cache - still does not work. Tried restarting computer - did not work. Works only using incognito mode (come on…). Needless to say I continue to be disappointed with what National rolls out without more thorough testing. Since we are being forced to use these systems National needs to take a bit more responsibility. Technicians don’t often understand the implications of their changes to the real world community.

3 Likes

@JeffreyBrandon - I have had no issues accessing scoutbook or IA2 on my newly imaged pc at work. As there were no cookies or cache saved from prior sessions I was able to go to scoutbook.scouting.org, click login and it worked. I am also able to hit the IAS link in scoutbook, then when IA click the scoutbook link and a new window for scoutbook opens. No issues here.

BSA IT is looking into the issues as we speak. The testing that was done on the test sties worked as expected. Updating systems does not always go as planned, and changing URLs involves more than just a code update.

I have seen reports that clearing cookies related to scouting.org may get past the issues.

You shouldn’t have to use a newly imaged machine or clear caches and cookies to make a site work. I’ve been developing ecommerce and web applications for twenty five years, these kinds of problems are usually reflective of poor architecture and programming practices.

@edavignon - not everyone is in scoutbook nearly every day. They needed to do more to proactively notify everyone of this change, including multiple emails with detailed instructions on what changed and how to clear cache, etc. I’m now going to have to waste an hour I don’t have today updating all of my parents on the change and how to make it work instead of getting other, more important work done.

1 Like