Can not aprove merit badge for a scout

It appears that Scoutbook had a “rechartering” now I can no longer aprove one of my Scouts merit badges.
I keep geeltting an error code.

What is the Scout’s BSA member number?

His id # is 124502769

@nicholastippett try going to Scout Membership and Unapproving it > Save > then reapprove it > Save

1 Like

If Donovan’s suggestion doesn’t work, you can also try re-setting your Troop Admin role.

  1. Go to the Troop Roster page in Scoutbook.
  2. Click on your name.
  3. Click on your Troop Admin role.
  4. Make sure the box is check next to “Position Approved”.
  5. Click Update.
1 Like

This is what error code is giving me

@nicholastippett did you try what I suggested? that should solve it

No it did not.
I checked and I am an aproved leader.

There is a visual display issue that crops up from time-to-time where roles like Unit Admin and occasionally get broken “behind the scenes”, but do not show up in a user-visible manner as broken. That was the goal of the suggestions that @DonovanMcNeil and @JenniferOlinger made. The former should “reset” the scout’s membership in Scoutbook. The latter should “reset” your unit admin role in Scoutbook.

Have (or one of your Unit Key 3) you already verified that this scout is correctly listed on your official roster at

This is fixed @nicholastippett

Yaaa. That fixed it. Thank you so much!!!

Now if I could add events to our calendar. I can not check any of or all the calendars to create the event.

@nicholastippett try calendar now

Nope, still can not check any of the calendars to add an event.

yeah seems like something is wrong with the unit calendar - I will turn in a ticket to developers

@nicholastippett are you just clicking My Calendar and then it just spins? Have you tried an Incognito/Private window?

No i am trying to add event to our calendars

@nicholastippett - are you trying this on a phone? If so could you try a pc, laptop or something other than a phone. I know that on my android it is challenging to select items.

Yes I am trying this on my android phone.
Doesn’t useing a desktop/laptop kinda of go against the whole point of scoutbook?

No offense but it is bad enough that does not do anything on smart phones.

On my iphone, I have very very good luck with Not the app, just the webpage. This would be for a different thread, but what issues do you see? I can run the reports, approve applications, etc. without issue.

1 Like

@nicholastippett - uhmmm no, it is just that android phone sweet spots for item selection can be tough. I have been successful bu not always. Just please discard the negativity and try on a non-phone device.

1 Like