Can’t login to scoutbook, please help

I am unable to log on to Scoutbook using the same username and password that I use for The message I get is “invalid username or password provided” but I’m using my accurate up to date username and password and can get into with them. How do I fix this in Scoutbook?

@PaulPhillips3 First have you tried a private/Incognito window?

No, what is that? I am not sure how to do a private/incognito window.

@PaulPhillips3 Go to File Menu to find it in most browsers

That option is not available in either of my browsers (Edge or Chrome).

FYI: I can get into with my username (pphillips73) and password fine (and my BSA member ID is 134726099), but when I try to use that same username and password to login to Scoutbook it give me the “invalid username or password provided” error. I also tried reseting my password in Scoutbook, but it says it sent directions to rather than my e-mail on file in and with the BSA. Any ideas?

@PaulPhillips3 - here are instructions


Based on the password message, it sounds like you are trying to go to the wrong site. Are you using

1 Like

Yes, I am using the correct site, it is just not letting me log in.

@PaulPhillips3 - it really does not sound like it based on the “it sent directions to”. Can you post a screenshot of the landing page and include the url bar.

Those options are not allowed on my Chrome and are greyed out on my Edge.

Now it is letting me in, so weird, thanks for your help

@PaulPhillips3 - glad it is working but it seems like you are on a restricted OS or account

hacked or hacker site “scoutbook . org”

“scoutbook . org” is not currently a BSA® owned domain. For more see

“scoutbook . org” website appears to be hacked or a hacker site.
That may also be true for the email server for that “scoutbook” domain.

My laptop was attacked, when I connected to that site.

I recommend scanning your system for malware or rebuilding your system


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.