Cannot edit "Date Joined Scouts BSA" in a Scout's profile

I have a Scout whose ESRA shows the wrong date for when he joined Scouts BSA. I’m trying to correct the date in his profile, but when I click the date to change it I just get a blank screen. I’m a Troop Admin in Scoutbook and I also had the Committee Chair try and she had the same issue. I’ve tried multiple different browsers and machines, but always just get this:

I was expecting to see a calendar to select the date, but there’s nothing. Not sure if this is really an issue with Internet Advancement, the data/permissions synced from Scoutbook, or something else entirely.

@JamesEnfinger - can you outline the steps and from what URL are you starting the process

Sure thing:

  1. I start in and open my unit roster, then click the Scout’s name.
  2. Under the Scout’s name, I click the button titled “Edit Profile.” The browser opens a new tab using (i.e. Internet Advancement) with the Youth Profile for the Scout opened up.
  3. In the upper left of the profile, there is a frame for his picture, how many merit badges he has earned, and the field “Date Joined Scouts BSA” with a date in it. I click the date and get the blank screen above.

If I go directly to and login, then open the roster there, then click the Scout’s name to open his profile, I get the same results.

@JamesEnfinger - thanks… I hover over the date and says to be edited by admins and parents/guardians and indeed click on the date does not present a way to edit.

I can think of two potential issues. One is cached pages. IA2 in particular seems (to me) to have a problem with caching things that are frequently getting updated, resulting in a need to force-refresh the page when you load it after any kinda of updates on the server side. Try holding down the shift key and refreshing IA2 once you get transferred from Scoutbook.

Another potential issue is with the Unit Admin role. Try “refreshing” your Unit Admin role by going to:

Scoutbook → My Dashboard → Administration → My Units → Troop ### → Troop Roster → your name

Then, click into the Troop Admin role, make sure it’s current, and save. This resets the position, and is path-sensitive, so you can’t just go via “My Positions”.

Thanks for the ideas - regarding the caching issue, I tried the force refresh of the browser and had the same problem. That made me think to try this in Incognito, but still had the same issue.

For the refresh of my position, I had checked Connection Manager earlier to make sure there wasn’t some weird manual override of this Scout limiting my rights to him and there was not. I tried the position refresh you suggested and still have the same issue - do you know if I need to wait for a sync between Scoutbook and Internet Advancement before that will take effect? If so, any idea how long that will take?

Sync typically takes overnight (give-or-take), but I would expect that Scoutbook pushes the authorization directly to IA2 when it shifts you over. Of course, I could easily be wrong about that, since I don’t know how the authority is implemented.

When you’re in IA2, which position is selected in the upper right corner under the fleur de lis emblem?

That might be where the issue is - earlier, I noticed that it said Assistant Scoutmaster (I’m both an ASM and Troop Admin in Scoutbook) so I temporarily ended my ASM position in Scoutbook so that I’m only a Troop Admin now. Even after the position refresh earlier, it still says Assistant Scoutmaster, so I guess it does need to sync. Not sure if that’s what causing the issue, but I can certainly leave it like this until tomorrow and see if it changes to Troop Admin, then see if it fixes the problem.

Screen Shot 2022-10-20 at 12.56.23 PM

You click the date and change the date then click save

Understood, but the problem is that when I click the date, I get this - no place to change the date, no calendar to select the new date, etc. Am I missing something?

is your screen zoomed in perhaps?

No, I’ve tried multiple different browsers, multiple different machines, browser maximized, not maximized, etc. When you click the date on your screen, do you get a calendar? Stephen above made a comment that he sees the same thing I see, so curious to see if everyone is seeing this.

@DonovanMcNeil - i see this on my pc… nothing there

Saw date 20 minutes ago??? now I do not

Screen Shot 2022-10-20 at 1.14.10 PM

I jumped back and forth from parent role and it reappeared

That’s interesting - now I see the date and can change it (after flipping to parent and back), but now get an error saying I’m not authorized to update his SB profile when I try to save it. I definitely have Full Control on his profile, per his Connections:

it will likely save anyway - SB Connections do not mean much in IA yet

It won’t let me save the change - any idea where the permissions to modify a Scout’s profile comes from, if not Scoutbook? I’m confused because the error seems to indicate that it’s due to a rights issue in Scoutbook. Is there something that needs to be done directly in IA?

just manually change it on the Eagle Application PDF

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.