Cannot grant Full permissions in scoutbook

I am a Pack Committee Chair, and until Dec, I was able to provide all level permission controls to my leaders for viewing and accessing scout details. In late December, is started to only be able to provide viewing rights to leaders. I am still listed as a unit admin.

I cannot see what has changed. I have cleared browser history, I have tried two different computers, and I have refreshed Scoutbook.

How to I get this fixed?


I looked at a couple of the leaders in your pack and they are connected to Scouts with Full Control or Edit permissions.

Scoutbook only allows adults who are registered leaders to be connected to Scouts with more than View permissions. If you post the BSA Member IDs (no names) of a few of the adults you are having trouble with we can look them up and determine if they are registered.

These are registered (den leaders). They have full control of scouts in their dens that were assigned pre-Dec. I registered 5 new scouts in Dec, and I cannot give these den leaders full control of these new scouts.

Please provide the bsa member number of these leaders and we can look into it. It’s possible some have duplicate accounts somehow.

Here are two examples

Jennifer Fountain…12823777
Travis Seay…12117251

Another issue…I cannot assign any of my leadership to new positions in scoutbook, because it says they are all expired leaders.

Is your unit in the recharter window?

My charter was submitted and it is on HOLD at counsel pending COR approval. I just got that update this morning.

All of my leaders are showing up as expired in the leader manager in my.scouting. I am wondering if this is the source of all the issues.

I have a unit in the recharter window and I was able to do all the things you can’t.

Can you provide a screenshot of the expired message you got, and which leader you tried assigning a new role?

I have run into a similar issue with our troop. Whenever we get new scouts, I have to give Edit Advancement permissions for all the troop ASMs. I usually do this through the Connection Manager. Right now, only the “View Advancement” and “View Profile” options are selectable. The other 3 options are not. We are in the middle of recharter and have not posted yet, so I assumed that was the issue.

Just tried to connect an ASM from an individual scout’s Connections page and it worked just fine. I have 10 ASMs and 12-14 scouts about to cross over, so that is 120-140 individual connections that would need to be made (not acceptable). Hopefully this gets fixed.


It appears that your recharter has not been posted. There is supposed to be a 60 day grace period after a charter expires, but there could be an issue with Connection Manager and the grace period.

Can you confirm that the ASM whose name you clicked on in Connection Manager you were able to connect via the Scout’s connection page?

Shows connected with “Edit Advancement”, which is the option I chose.

We have duplicated the issue with Connection Manager and reported it to the developers.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.