Leader without full control

I have run into a new issue that I can’t figure out. I have 3 leaders (1 existing and 2 new) over 2 different dens.
Tonight I was going through moving some scouts that have not been active when I noticed that the leader could only view profile and achievements, no matter how many times I tried it would not “save” full control.


Were you trying to use Connection Manager? There is a known issue that is preventing setting connections to anything beyond View Profile and View Advancement. We expect the issue to be fixed soon.

I tried in connection manager and going into individual scouts connections and neither worked.

Until tonight these leaders had full control.

Post the BSA Member ID of the leaders (no names) and we will investigate.

Thank you.





Please try again. A fix for a Connection Manager issue was released tonight. This may have fixed your issue with setting connections on the connections page as well.

That fixed it , thank you.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.