Unable to access Internet Advancement all of a sudden

All of a sudden, I have lost access to our Troops Internet Advancement. I am a Troop Admin and The Troop Advancement Chair. (both roles have been verified in Scoutbook and myscouting.org)

(I can see my own scouts, but not the troop)

Can someone look at this please?

Thank you
John Kramme
BSA ID: 126360789


The same thing has happened to me. 133437684 . I can see my offspring and myself, but no one else in the Troop.

Same for me as well. MID: 12020867.
*I am the Unit Advancement Chair and show full access in Connections.

Member ID 120361678: Error Message
I am the Scoutmaster!

I am also unable to access anything in Internet Advancement other then me and my own son. I have both Troop admin privs and Key 3+3 privs. I verified that I still have all of those privs.

This has to be a system issue. I can’t see my Troop either, but I can see my pack. I can also see my kids. I have been getting error messages since last night. Now today, stuff is missing. Not really helping when I was trying to order COH stuff.

1 Like

I’m having the same issue. I have tried several different work-arounds but I’m getting nowhere. I’m listed as Unit Advancement Chair, Training Chair, Key 3 delegate, Troop Admin, and Committee Member. I get the same error message Marion Shaffer posted.

Log another unit leader that cannot access Internet Advancement (www.advancements.scouting.org). It was working either yesterday morning or Monday night and stopped last night.
Eric Lokker, Troop 54, ID:125622720

Add me to the list - What a great product!

Yes a new API messed things up - Developers are working on it

Add me to the list too. I added stuff yesterday and can’t get in today.

Same here. I can access our boys’ troop, 492B (I’m the ASM), but not the girls’ troop, 492G (I am the SM).

The developers are aware of the issue

1 Like

I have the the same issue that just started. I’m not able to see the troop and the pack comes up only and I’ve always had access to both until now. I’m a Key 3. Member ID: 6311945

I had the same issue last night (as Key 3 delegate), but this morning I have access restored to my unit. Maybe they fixed it last night?

I have the same problem, can only see my son’s info. It says they are working on it so hopefully it’ll be fixed soon.

Last evening (31 Aug), I could only see my pack and could no longer access either of our troops. Now this morning, I can still get to the pack but only one of our troops. I hope this is still being worked on.

I’m having the same problem: BSA ID: 105926280
Karen Haaser

Same problem - I’m Key 3, on both Pack and Troop - Troop is GONE!
Restarted computer, my.scouting, checked modem
Please advise

@DonovanMcNeil @jacobfetzer - any update on this? What is the ETA to a fix from the developers?

1 Like