Unable to log into Internet Advancement

It won’t let me log into IA either directly or via Scoutbook, on either desktop (Safari), iPad (Safari or Duck Duck Go), or iPhone (Safari). Clearing cookies didn’t work. I’m a Key 3 & troop admin, both current in Scoutbook. When I try logging into IA directly, an error message, “Error You do not have access to view this person’s profile” shows. Help!!!

The developers are aware of a login issue and are working on a fix.

1 Like

Thanks for your help.

Ditto–Can’t get into IA since last evening (7:00 pm CST). I don’t get any error message. I have an icon that just spins and spins! Help!

1 Like


With the non-stop spinner, try holding SHIFT and clicking the browser’s refresh icon. This happens to me frequently and that usually resolves it.

Mine spins and spins too, if I try to access via Scoutbook.

1 Like

Tried the shift key trick–without success.

1 Like

Hi, thanks! I tried this, several times with no success. Frustrating! Our COH is next week so I wanted to run my report, take it to the council shop, make purchases and work on that this weekend! Everything was working fine a couple of days ago.

Thanks for the help!!

1 Like

I am unable to access it as well. Tried 4 different Browsers (Edge, Chrome, Brave, & Firefox) on two different computers. Both running Windows 10. I can not access it from my phone either. An Android…

There is a known issue that is preventing some people from logging completely into Internet Advancement. After login all they get is a spinner. The programmers are working on the fix. The earliest we expect the fix in production is sometime Monday.

Thank you for the Update. I will be waiting, I got some updating.

The programmers made some changes, please try accessing the activity logs and Internet Advancement again.

1 Like

Whohooooo!! I’m able to get in. Thanks!!


Are we still waiting on a fix? I was told to send an email to someone at the council, and have heard no response.

According to @WilliamNelson’s post above, there was some sort of fix rolled out, Are you still having issues accessing the system?

Yes, I am still having issues.

OK. What is your role in your unit, and what specifically are you trying to do?

I am the Pack Committee Chair and I take care of all Scout advancement. I need to specifically Update our AOL Weblos before crossover.

At the risk of asking what may seem like a stupid question, have you verified that you are still listed as pack committee chair in my.scouting.org? If the paperwork wasn’t processed correctly, we’ve lost people (or had a second account created) during recharter. Access to IA2 relies on positions as defined at my.scouting.org, rather than what’s shown in the Scoutbook rosters. We’ve had issues with that before in my unit.

Charley, I did confirm on the website that I am still listed as the Chartered Org Rep & Committe Chair. I am also the same person who completed the recharter. I don’t know what else would have changed. Where else would I need to check?