Can't access child Scout's Info


Both me and my wife can’t access one of our child scout info on

Child ID: 133667576
My ID: 12491919
Wife ID: 12044783

There is also a error “Logged-in user does not have access to this API”

This doesn’t happen to my other 2 sons.

Thank you.

If you are using Internet Advancement, then try a hard refresh: hold the ctrl key down and refresh the browser window.

Tried hard refresh doesn’t work. I also tried other browsers, same issue.

I reset your parent connection, see if that fixed it.

Unfortunately it is not resolved. Tried both my account and my wife account. Here’s a screen shot, maybe it will help figuring out the issue.

@Keen_HonWong - perhaps you both would be in a better position if you logged into the only time you would need to be where your screen shot shows is for service, camping and hiking. Logging in via scoutbook should if looking at any of your children should bring you to the proper log location.

In the dropdown at the upper right, are you selecting your parent/guardian role for that specific scout?

Yes. Any only my youngest son got this error.

@Stephen_Hornak I am trying to update my son’s profile. And I was directed from to this page.

@Keen_HonWong - that error shows up even if you clicked on a scout in the dropdown?

Only if I click on Noah Wong. Not Wei Zhi Wong or Wei Zhe Wong.

The difference that I can see is that the parent in Akela for your youngest is your wife, not you. I’m seeing the same behavior with my wife’s account. Whereas mine, where the Akela relationship is set, works fine.

Actually, something is weird with your wife’s parent relationship. I usually see it in both directions. But in this case, I only see it as see is the mother of N. I don’t see it as N is the son of her… which I do see for the other two. Can you ask your registrar to set the parent connection in Akela for both of you?

The registration for Child ID: 133667576 doesn’t look correct.
Ask your council Registrar to add an address to the record. Also check the parent relationships. And double check the registration. If they have difficulties, they can submit a ticket.

Unfortunately it doesn’t look like a Scoutbook issue but a Registrar Tools / my.scouting registration issue.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.