Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Can't add training

Using the Training Manager, I am unable to add training for four of my adult leaders who attended a Leave No Trace awareness seminar at summer camp. I can search for their individual records, and I can use the Search/Add dialog to enter the course date, but when I try to search for a Scouter by BSA ID or by name I get a message stating “You are not authorized to use this API.”

Should I not be able to add a training completion for my adult leaders as a Troop Committee Chair?
Note - I get the same result when I go in through my district, where I am a Key 3 Delegate.

1 Like

It seems to be a bug. I am getting the same error message.

1 Like

I concur. I successfully entered IOLS training for one of our ASMs 8 days ago. However, right now, I am unable to enter training for another of our ASMs who recently completed First Aid/CPR training. Same error message on both Firefox and Chrome, incognito/private browsing window or not.

I just logged in this morning, InPrivate Browsing window on MS Edge, and was able to add training without issue. I am an ACC.

I suggest trying it again today, and see if the error has not been fixed.

If it still exists, please PM me your BSA ID number, and My.Scouting username so I can have it looked at for you.

Thanks, Ron. Yesterday, I also added the Unit Training Chair functional role to see if that was the issue. Trying it today, the problem is still present.

Member ID 115842736

There doesn’t seem to be an option to initiate a PM, BTW.

Only the Admin’s can start a private message.

1 Like

Update - after @RonaldBlaisdell submitted a ticket, this is fixed for me.

I am having the same issue. In July I was able to enter training done over the summer by one of my ASMs at summer camp (Safety Afloat). Now I try to enter additional training today and I get “You are not authorized to use this API.”

I am Key 3 Delegate and Unit Training Chair (I confirmed in Organization Manager → Position Manager).

Any ideas?

@WilliamsburgScouter Assuming that you are not trying to add training for yourself, I think there is probably a bug. If you wait until tomorrow, the bug might resolve itself. If the bug doesn’t resolve itself, then we will probably need to report it.

1 Like

I have also shared that we had this error pop-up on Sunday with BSA IT.

@RonaldBlaisdell - I can confirm that I get that API warning as a k3 in my units when trying to add training to another leader. Thank you for reporting it. I suspect perhaps the new recharter may be in the way of the api.

2 Likes

And everything now works. Thanks!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.