Cant connect MBC to scout

I cannot connect the MBC to the Scout in scoutbook. I have their email and their name. I see their profile when I do the general MBC search. But when I try to add connection it says it cannot find anything to meet the search criteria. I have tried putting their email in the search box and their full name. I have tried other MBCs names and emails and I get the same results. It cant find anybody. What gives?

1 Like

Yes! I have the same issue

This is a known issue.

Last week I was able to connect another scout to the MBC so is this a new thing? Is someone actively working on this issue?

We believe it is a result of tonight’s push. The developers are aware and are looking into it.

1 Like

The issue causing connection search to fail has been fixed.

Issue is still ongoing. Just tried to add a connection to a MBC for my son, and it won’t even pop up the search button. It just goes directly to adding someone new in scoutbook through email invite.


This is a known issue due to a security fix that was applied last week. You will need to ask a unit admin to connect your Scout to the MBC.

The developers are working on a fix but we do not know when it will be released.

Same issue, ongoing.

Since the SM (or their designated ASM) is the one who consoles the Scout on MBCs, this new limitation should be a non issue as said SM/ASM should be a unit admin.

1 Like

Put differently, unless a parent is the SM or ASM, a parent should not be making these connections.

1 Like

I am an SM. The problem seems to be able to be resolved for me right now but it’s happened several times.

1 Like

@CasandraCartagena You had 2 Troop Admin positions open in the same troop. That might have caused a code conflict. I ended one of them.

You can also try re-setting your Troop Admin role.

  1. In Scoutbook, go to the Troop Roster page.
  2. Click on your name.
  3. Click on your Troop Admin role.
  4. Click the “Update” button to save.
1 Like

Perhaps this will help in some cases… Make sure that the MBC is not already connected to the scout, from a previous merit badge or for other reasons. If they are already connected, they won’t show up in a search and the system will act as if you can’t find them when you try to connect.


Unit admin cannot make a connection, either.

Same issue - ongoing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.