Can't get Individual Advancement Report

I clicked on individual advancement report, selected the whole troop of 36 Scouts, clicked the generate report bar and after several minute of waiting got a message reading, " Whoops! We encountered an error trying to process your request. Please go to Scoutbook Bugs - Scouting Forums to report this issue."

This has worked for several years until now. I use Firefox as my browser and refuse to agree to Chrome’s EULA.

@JulesEibner - please be aware that the IAR is out of date with the new requirements. You would be better served with the Scouts BSA History report.

Putting aside @Stephen_Hornak’s point, did you also try with a single entry? I’m trying to differentiate between some sort of a time-out error due to multiple records (not that 36 is a lot, of course) and another error that’s impacting even a single entry. It generated OK for me with a few scouts selected, but “hung” for 20+ entries.

@JulesEibner Have you tried running the report with fewer Scouts? Try half your troop and see if that works.

1 Like

Thanks for the reply. The Scout History Report doesn’t really meet my most frequent need which is just to flip through the pages to see who still needs a certain requirement for one of the lower ranks. If the IAR is out of date they should either fix it or remove it. From my point of view, removing that report would be detrimental.

As far as I know, the IAR report is up to date.

However, what might suit your need better would be to use Report Builder Manager to show which requirements your Scouts are missing. You could have one report each for Scout / Tenderfoot / Second Class / First Class.

Thanks for the suggestion. This evening it started working again. Perhaps something was loaded down, running slow, and encountered some sort of time out when I was trying to do it earlier. Or else, maybe they had a problem and fixed it.

With Report Builder Manager, you can create a custom report that looks like this one for First Class:

1 Like


There were no fixes released for IAR.

I am having the same issue with IAR. I’ve tried selecting a single scout and have the same issue as if I selected all scouts.

I want to report that this issue is ongoing. have not been able to successfully run IAR all week. I usually run them Monday for our weekly meeting, so I’m not sure when it broke, but sometime between April 29 and May 6. It fails for both single-scout and whole-troop reports.

Alas, the History Report is formatted much less ideally. The IAR is front-and-back for each scout. The History Report is variable length, which makes printing it for a large troop incredibly cumbersome.

Tried this morning, still can’t access, regardless if it is a single scout or whole troop

Same issue Monday morning. If I print 1 scout record, it’s completed; if I do 3 it’s slow but done; if I do 4 it’s very slow (long wait); and if I ask for all 16 scouts it “spins” then gives the Whoops message after a long wait. Seems to be timing out/slow retrieving the reports? Using MS Edge. thanks.

This is still happening most of the time. I probably tried it 5 or 6 times throughout the day yesterday with no luck. Went to our meeting without the data. Last night after I got home it worked. I entered some advancement from yesterday’s meeting this morning and tried to get the report and it failed again. Perhaps it has something to do with the combination of slow processing and a timeout setting, so that it works if the system is lightly loaded. PLEASE FIX IT

I’m looking to get the report for the whole troop. It needs to be concise. We’re all used to working with the IAR. BTW, I always download the pdf and work with that because Scoutbook is slow and takes too many button clicks to go from one Scout to another.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.