Can't log into Scoutbook

(If you are reporting an issue with My.Scouting, please include all of the following items so we can better assist you:
1) Hardware: Desktop or Mobile (if mobile, please be specific)
2) Operating system
3) Browser
4) Browser cache has been cleared or you are using a private browsing mode (aka Incognito Window in Chrome)
5) Member ID & Council of person affected
Thank you!)

I am unable to sign into Scoutbook…ive tried numerous things. Every time i try it says i dont heve SSO setup. I have done this and also i cant click on tbe link. I need help

Jeffrey Krisik

Member ID134549366

Are you using the username/password combination that you use at my.scouting, or an email address to log in? Or are you using Google/Apple credentials to login?

@JeffreyKrisik You had a duplicate Scoutbook account, but they have been merged.

Please try again.

It isn’t letting me log in again. Says username or password not valid?

This is only happening for Scoutbook…I can still log into myScouting.


I’ll look into this for you


Are you using your ID that is your first initial, middle initial and last name?

yes It is…I’ve had issues a few times with this …


Do you happen to have autofill turned on for your ID/PW in Scoutbook? Everything looks correct when we view the database. You should be able to log in with your ID.

No…I just tried now and it works…it’s possible I was trying to sign into wrong url