Can't print YPT certificate

When I visit and hit the print icon on the row for my YPT training, I am taken to a page that displays nothing but this JSON:

{ "ResponseDate": "20210512130310", "ResponseValue": "", "ResponseCode": "-2", "ResponseMessage": "Enrollment ID is invalid." }

My training is valid and doesn’t expire until 2022.

Ok you’ll want to go to the bottom where it says completions. Search for youth. Push the button for Youth Protection Training Certification. At the top there will be an option appear that says certificate. Click on that and it should open a PDF of the certificate.

1 Like

Thank you. That worked as a workaround. I’ll mark as a solution once someone from national’s IT notes acknowledgement of this bug.

The issue is when using this print icon:

Don’t use that Icon. Mine does the same thing when I click on it.

Yup. The icon needs to go away, or the underlying functionality needs repair.

1 Like

@RickHillenbrand just tagging to see if you can pass along to development about the printer icon not working (couple of posts up for graphic).

I have validated and reported this issue.


IDG (BSA IT folks) has been informed. Thanks for bringing this to our attention!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

I was just told by IDG that a fix was pushed to production this week.

1 Like

Thank you. Just confirmed from my end.

What is IDG?

IDG is just department slang for BSA IT - you know BSA love TLAs

Sorry - I reverted back to acronym lingo… IDG = Information Delivery Group (what BSA occasionally calls their Information Technology folks internally).

This is still not working properly.

I just tested it, and it was working fine for me. Might want to try clearing your cache and see if that helps. Also, this post is 10 months old, so you might need to open a new case if it’s still an issue for you - which I believe should be done by contacting a professional at Council, now that users can’t report this stuff directly anymore.