Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Cant send messages after domain change

Since the domain change last week, I am unable to send any messages using Scoutbook.
This is a major problem becasue this is our primary source of communication to the Troop.
It doesn’t matter which browser I use, clearing cookies, or using private or incognito mode, I get the same error: “We could not send your message. Please try again.”
There is no error code or any further information.
Capture

An issue with including attachments was reported previously. Are you using attachments?

Also, check my dashboard > administration > my account > email. Is your correct address listed?

no attachments.
my email address is correct.
I can send an email to myself. as soon as I add scouts and/or other leaders, I get the error message

Are you a unit admin?

yes. Troop Admin & Scoutmaster

Ok. Try this. It has to be exactly this path.

  1. Go to the troop roster.
  2. Click you name
  3. Click your current SM position.
  4. Make sure the position approved box is checked.
  5. Click update.
  6. Repeat for the troop admin position.

updated both positions. all are verified. tried to send message again. got the same error.
Capture2

Are you able to send a message to just one person (other than yourself), maybe a spouse or an ASM, as a test?

The other thing that’s interesting is your troop MBC position. Do you also have a council MBC position listed?

interesting. i can send a message to my son, its received.

the MBC position is listed as Troop only. as of right now, elected not to publish at council level. this is correct.

That’s making me think it’s an issue with a particular person you are trying to send to. If you use the print roster button you can see adult email addresses to see if any look weird. You won’t be able to do the same with the scouts, but it’s a start.

seems like that might be the issue. thanks.

Another possibility to help narrow it down is send it to one family or one patrol at a time. By going to the patrol page and clicking send message, it will automatically include all the members of the patrol and their parents.

When you are on the send message page, do you see any parents in the parent column that don’t have their children’s names under them? Do those scouts happen to also be listed in the scout column?

Keep me posted regardless. At a minimum, there should be better handling of the situation if there’s an individual who you can’t send to.

Yep. I’ll have to go through the roster bit-by-bit to find one or more accounts causing the error (if that is in fact the cause). You’re right, the error message should contain enough detail to understand why the message can’t be sent.

To add on to this… I am getting the same error but noticed it only happened when I had the following:

Once I fixed both of the above errors, the message seemed to send alright. Hopefully we can get them corrected soon.

Thomas.
You got it exactly.it was the BBCode in the message causing the error.

I am having this issue. Below is a screenshot of the issue with the message trying to be sent.

I have ran through the steps to make sure I am flagged as the troop admin and scoutmaster. Both are set correctly.

The email is only going to a subset of Scouts and parents. In trying to print the troop rooster, I am getting the following error.

I have tried sending the message from an in-private and standard browser page with the same error in both situations. I am using MS Edge and Chrome which both have the same issue.

Is there a fix coming for this?

@AnthonyVerguldi_Jr, have you tried sending without the bbcode links? Bbcode was reported to be associated with issues in another thread.

Thanks @CharleyHamilton. After doing some research on another issue and reading through the tread again, I was able to solve the issue. I changed the URL link from an alias (e.g. [ url=some ugly url here] nice text here[/url]) to just a pure URL link (e.g. [ url]some ugly url[/url]) then I was able to send the email.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.