Can not send message

I have been trying to send a message for 3 days now and every time I hit send the program goes into an endless buffer. I have restarted the computer several times, tried a different browser (which would not recognize my login), sending a test email to only myself using a letter s in subject and message fields and I get the same failure each time.


Can you try an incognito or private browsing window?

I was having the problem where I got the endless spinning “Sending” message. I changed to an incognito window in Chrome and was able to send an email. Does this mean I need to clear my cache for normal usage (i.e. non-incognito)?

I was using Google Chrome and flushed my cache, rebooted and reset my entire network. Still the same. I went to Edge and it worked just fine.
I’m guessing a Chrome Update or Scoutbook update might have caused this minor hiccup. So try another we browser for the short term solution to use messaging in Scoutbook.

I just did an email withan attachment and i got my copy of the email and trust others did as well. It was via Firefox on win11

Seems to have stopped sending SB mail on Saturday. Usually this mail is buffered and when the SB IT realizes it they’ll “restart” and push all the email out.
I’m waiting on two messages.

Now I’m wondering if it will be pushed out or if I should resend the messages.
SB needs a feature to keep a copy of all sent messages.

1 Like

I have a theory that sometimes after a unit’s Recharter has been fully processed, unit Admins (who are not also one of the unit’s Key 3) sometimes have their Admin role get glitchy in Scoutbook.

Try having another unit Admin (not yourself) reset your Admin role in Scoutbook. Here’s how:

  1. In Scoutbook, unit Admin (not yourself) goes to the unit Roster page (Pack Roster / Troop Roster / Crew Roster / Ship Roster, as applicable).
  2. Click on your name.
  3. Click on your unit Admin role.
  4. Make sure the box is checked next to “Position Approved”.
  5. Click “Update” to save.

Some other troubleshooting ideas to try:

  • Clear your browser’s cache and cookies.
  • Turn off / disable any extensions or pop-up blockers.

@MichaelPawlik Please try sending yourself a test message. Scoutbook’s messaging system is working for me this afternoon, so I don’t think it’s a system-wide issue.

Tried all of above and still will not send out any messages??

@RosieThiel You and one of your Scouts both had the same e-mail address in Scoutbook. I removed the e-mail from his Scoutbook account.

Try logging out of Scoutbook, and log back in.

Interesting. I am using Firefox and am having trouble sending messages through Scout Book. Thank you.

I am the Troop Committee Chair / key 3 / Troop admin and I am having the same problem. Messages will not send, with or without attachments. I am using Firefox. I will try other browsers, but this may be a system wide issue.

@GeraldEagan - i am likewise in my troop. But my message being sent i am not sure if system wide. I received the message in my comcast email and work email so it worked.

Is it possible that the difference in observed behavior is reflecting an issue that’s different among the various servers? Not sure if there’s some sort of “geographic” pattern to the difficulties that might suggest this (or rule it out) in some cases.

ETA: For those who aren’t already aware, the server name displays in slightly different color font just below the BSA and Scoutbook logos at the bottom of the page:

@CharleyHamilton - good point. let me post the server that I am on


Sorry Still no luck, It just spins??

@RosieThiel - xan you post the server you are on, OS version and browser and if you have addins on the browser.

Works on…

Having the same issue trying to send our weekly email. Tried two different browsers. The first couple I was trying to attach a file and it would just hang around 75% upload, so I just linked to the file instead, and then it just spun. Switched to a different browser and it said the message was sent but it’s been a couple of hours and no message. Sent two additional test messages that say they sent that I have not received. Server from the most recent attempts is AWSWEBSCTBK5C
MacOS 10.15.7, first browser that just kept spinning was Firefox, then tried Firefox with the scout book add-on, then Safari said sent but haven’t received it.

Edit: Tried again via Remote Desktop to a Windows 11 computer at another location, is also server AWSWEBSCTBK5C, no emails being received.

I used my MacBook this AM and got the message to send. So I don’t know if I still have the problem on my home computer or not?