Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Can't view or update rank requirements for Cub Scouts

Hi! I’m the CC for the Pack which both my daughters are registered (one working on AOL, the other just registered for Lions). Since my older daughter switched packs in February, I have not been able to update her advancement requirements in Scoutbook. I thought it was because I was no longer her den leader, but now that our Registrar finally got and processed my papers as CC and I’m showing up as one of the Key3, that no longer makes sense. My daughters and all the other kids in the Pack are showing with “green dots” indicating full control. My position is showing correctly and I have the little keys next to my name. When I click on ANY of the kids (including either of my daughters), I can see their advancement so far, but when I click on a particular adventure to update it (such as Outdoor Adventurer) Scoutbook just routes me back to the main page for the Pack.

I am also on the Committee for a local Troop, and I have not had any problem marking off requirements for those girls.

Nobody else in my Pack uses Scoutbook at all, or has ever even logged in. I’m leaning on the Cubmaster to give it a try, but it hasn’t happened yet.

I had been using Safari both on my laptop and my phone with the same exact results. I recently thought maybe it was a Safari problem so I tried it on FireFox, but there is no change.

Any thoughts about what could be wrong?

is it only your daughter you see this behavior with? You could try going to your Positions > click the Admin > click update

Are all of the Cub Scouts assigned to dens in Scoutbook?

(a) No, I had the same behavior for all the Cub Scouts,
(b) They are all assigned to dens now; I did that the other day when I finally got my status as Committee Chair updated in Scoutbook, and it didn’t make a difference, and
© Apparently, posting about it here was the solution. Because literally it wasn’t working, even though I kept trying over and over again for months, I posted this question, and then I tried again and it worked.

So. That was weird. But it’s working now. Or at least was this morning when I tried again right before heading out to work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.