Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Crew Advisor cannot leader approve Scouts BSA Rank

I am a Crew Advisor and have lost the leader approval button on one of my youth for Scouts BSA rank. The youth is not dual registered and his Scouts BSA toggle is activated. I can see his rank advancement and mark off as completed but not leader approved. I can leader approve his MBs but not rank. I have checked and this bug is consistent with other youth in the crew. All youth in the crew are only registered in the crew and working on Eagle Rank through the crew as well as Venturing Advancement. This same bug occurred a few months ago but was fixed and has now reoccurred. Please fix quickly as I have 2 youth preparing for Eagle BOR and need to get advancement updated. Thanks in advance!

Doty
Can you give us their member IDs?

Bill,

134304715 is my primary concern as he is preparing for his Eagle BOR but noticed the same issue with all the youth in my crew. What is interesting is I can still leader approve Eagle Palms but not other rank related advancements. Thank you for your assistance and in such a short amount of time!

124641251
124639480
126645126
126447038
132963750
124714487

Yours in Scouting,

Doty Robbins
Crew 1645 Advisor

(Names removed by moderator)

Try the following: Log into Scoutbook, click on your dashboard, your crew, your crew’s roster, click on your name, click on your positions. Click on your crew admin position and then click update. You have to access it via the crew roster. Then log off and on, and see if that fixes it (that will reset your admin position in the crew)

Bill

@DotyRobbins yes this is a bug - there is a work around using the needs approval report though - this is being reported to developers

This is effecting SHIPS in the same way

Bill,

I tried the steps you suggested and this did not fix the problem. I also tried updating my connection to William using the same steps and still I am unable to leader approve his Eagle Rank requirements which he has completed. He has both completed and not completed requirements for his Eagle Rank, however, the requirements which are completed I cannot leader approve.

Doty

Donovan,

Thank you for the work around!

Doty

Donovan,

The work around is not working for me. I go to the needs approval and it will not show me the requirement to approve so I cannot check them and when I hit Mark as approved it tells me to select requirements which I cannot because the requirements are not showing. I tried hitting select all and I get the same error.

Doty

Did you try Quick Entry? for the ones that need to be marked completed? The programmers won’t be back until Monday night because of the holiday, and a fix is not likely until late Wed night at the earliest.

By the way, for the Scout going to the Eagle BOR, you probably just need to make sure that Eagle Scout Application is properly filled out, the correct dates marked on the application and for SM conference, positions of responsibility dates marked correctly, etc. The Eagle application that comes out of Scoutbook is editable. As long as the Scout has the 21 merit badges recorded the EBOR should take rest from what is on the application.

The quick entry worked! Thanks for all the help! Hopefully the bug will get fixed soon but until then the quick entry works for a work around at least for me! Thanks again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.