Cub Scout adventures don't show completed

When I entered completed requirements for my den today in scoutbook the adventures don’t show the accurate percent completed and they don’t register as completed toward rank. Some of the adventures show an inaccurate percentage complete, while another shows which requirements are done with a blue check, greys out the others as not needed, but still shows 0% complete. I’ve never had this problem with entering completed requirements before, so I don’t know how to fix it.

Kirsten Cox

1 Like

Can you specify which adventures you’re seeing issues with, and possibly provide the BSA ID (no names needed!) for one or more of the scouts showing the issue? That can help SUAC with diagnosis.

1 Like

I noticed this today for adventures that have sub-requirements in particular. And also some issues with quick entry. I’ve reported the latter and will soon be reporting the former.

I am noticing this issue yesterday and today with various scouts and various adventures. One example for anyone triaging this issue:

BSA ID: 136215422
Adventure: Forensics

I noticed this yesterday on several scouts on Scouting Adventure and Outdoor Adventure. Maybe one other. It seems that once I signed off the remaining requirements via quick entry, they showed checked and approved, but the “adventure percent complete” didn’t update. I just clicked on the top level and signed them off. Easy enough work around, but something has changed.

One scout who is having this problem is
bsa 13689761
She recently finished Games Tigers Play and did all of the Sky is the Limit and they are not recorded correctly. Thanks for the mention on how to over ride the system and make it show the adventures as complete, but something changed in the system and they should change it back.


The developers are aware of the issue and are investigating.


I also have this problem. Please fix ASAP! When will we know when it is fixed? I think an email should be sent to all users when it has been resolved. Also, it would be appreciated if there are any issues that do arise in the future to let all users know. Thank you.


All Scoutbook updates are posted in the Scoutbook Change Log - Scouting Forums

1 Like

and you can subscribe to the change notices (or any of the forums in principle) by going to the forum, clicking on the bell icon in the upper right corner of the page, and selecting “Watching”. That will email the email address associated with your forum account each time a new post is made to that forum.

Folks can use incoming mail filter rules to automatically flag and/or sort those messages to avoid being inundated.

I do have that clicked. Do you know when this will be fixed?

@MonicaPeterson - this is affecting a number of items and a fix if found will need to be tested and then released

Generally the BSA does not publish timelines for fixes or feature changes. However, since it’s actively being worked on as described above, it sounds like it’s on a priority path (as opposed to the “when we get to it” list). As @Stephen_Hornak noted, it needs to be diagnosed, fixed in principle, tested on the development/testing system, then pushed out to the production servers for the rest of us. Even if it’s the only thing they’re working on (which I’m betting it isn’t), that sort of work takes time to reduce the chances of breaking something else with the fix for this issue.


In case it helps, here are the related issues I was having today:

When using Quick Entry within a Lion adventure:

  1. Enter + approval will check the individual boxes but not recognize completion of the entire loop.
  2. If I undo the approval, it changes each individual requirement to completion and will complete the loop as well.
  3. Enter only (without checking the leader approval box) gives the same result as #1
    This was happening on multiple required Lion adventures using a PC, Chrome, Windows 10.

Bear Necessities is not showing completion when 1-4 are marked complete. It states 25% completion of the overall loop. I also entered the date as 9/26 and it shows at 2/7 (today’s date). When I try to undo the completion it says nothing matches the criteria (all dates, my entry). If I go into each individual requirement I can change the date and then it marks completion and approval of each requirement, but still not the overall loop. After changing the dates individually I was able to mark the entire loop complete with the Earned box at the top.

The same thing happened on Fellowship and Duty to God. I logged out and back in to see if it was an issue with timing out. No change. I was able to unapprove and it still shows a 33% completion with requirements 1, 2a, and 3b checked.

The developers think they found the cause of the issue with advancements not auto completing. They hope to have a fix in place during the push on Wed night.


So in the meantime, should we continue to mark adventures off even if they aren’t showing up in advancement right now? Or should we just stop entering until this problem is fixed?

You can continue recording advancement, just be aware that auto completion and percent complete calculations are broken.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.