Cubmaster cannot log into despite changing password

Hello All,

Our Packs Cubmaster is having difficulty logging in to my.scouting and has asked me to post this message on his behalf. He has been able reset his password, but the new password(s) do not work when he tries to use them on my. Scouting.

He has attempted to “recover” his account several times on both he desktop and mobile versions of my.scouting. He is using Windows 10 and has tried to use Chrome, Edge and IE. After reading other internet posts, he cleared the cache and has used private (incognito) tabs. Unfortunately, none of that works.

Sometimes, the recovery process returns the correct information (name, DOB, Email address, zip code and member ID). However, sometimes it returns the same information, but with an incorrect email address (q******* No matter what he tries, he always gets the same error: “Invalid username and/or password provided. Please try again later.”

Finally, he was able to have the system perform a password reset and send him his username with a new temporary password. However, even those credentials (provided automatically by the system), tells him its an invalid username/password.

Any information that you might be able to provide would be greatly appreciated!

Username: (removed by Moderator)

Member ID: 12901972

Thanks so much for the help!!

The Last name did not line up - I fixed that . I would suggest them going to and using the BOT in the bottom right corner to reset password - just type “forgot password”

Thanks so much for the help! Unfortunately, that did not appear to fix the problem. He did try what you said just now and had the same result as before.

He was able to change his password himself and also tried having the BOT assign him a new password that was emailed to him. None of those seemed to have worked. Any other suggestions would be greatly appreciated.


Council can reset password