"Edit Merit Badges for MB Counselors" doesn't work

I’m an MBC. I’m working with someone on Communication MB.
Last week all was good.
This week, I select:
Edit Merit Badges for MB Counselors
→ Communication
→ <The Scout’s name>

It loops saying “loading” for a few seconds, and then goes back to the “My Merit Badge Counseling” page … right where I started.

I’ve tried this on iPad and Mac.
I quit Safari and restarted.
I tried Chrome.
… all with the same result.

Has anyone else seen this?
Is it a known issue?

The developers are looking into this.

I am having the same issue. I have been working as a MB counselor with a scout, and he only needs a few elements to complete. I had met with him today, but was not able to indicate completion. Got the same access issues as you.

Can you let us know when its fixed, please.
I’d like to meet with the scout again ASAP!

It will be announced in the Scoutbook Change Log topic.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.