BOY SCOUTS OF AMERICA

Scouting Forums

Error message entering advancement

I’m using Firefox to log into Scoutbook. Every time I’ve tried entering advancement items (merit badges or ranks) I get an Error message. It’s a very think box that appears above the window I’m using to enter information, and simply says “Error” in red, with no explanation. Any ideas?

@MarkOwens1 - scoutbook or internet advancement? Perhaps a screen shot or two ?

sounds like Internet Advancement - steps with screenshots will help to diagnose


This is the message I’m getting (hopefully it’s showing up correctly)

For fun and excitement, I logged in using Google Chrome and received the same message. However, for a different scout I was able to successfully record a merit badge. Any ideas would be more than welcome!

is it just this one scout? is it just this one MB?

I receive the error message for all scouts except one – his badges were all successfully recorded.

That scout happens to be my son. I’m not the key 3 person on ScoutBook, but was added by the committee chair so I could start using ScoutBook (until now we’ve been using Troopmaster). Is my problem more of a permissions issue with my account? I’m listed as the unit advancement chair.

@MarkOwens1 - you are in internet advancement from your screen grab. When did you have the advancement chair added in my.scouting.org? Just for the fun of it what happens if you log into scoutbook.com/mobile what do you see there?

@MarkOwens1 if you post your BSA# the developers can look into it easier also

Hello,

I am getting the exact same error. I am Advancement Coordinator for our troop, and I am trying to input all that was earned during summer camp. I’ve tried Firefox, Chrome and Internet Explorer (Bing, whatever they call it). I too would appreciate any info on getting this resolved.

@FrancesDeoliveira you are designated the Unit Advancement Chair in Organization Security Manager?

@DonovanMcNeil Where would I go to check that. I mean when I check my profile it states Unit Advancement Chair under my name. When i click on the Scout symbol (Group drop down button) at the upper right next to the Settings symbol it says Position: Unit Advancement Chair. I just do not see where it says Organization Security Manager. I’m sure it’s right in front of my face.

it is a my.scouting.org feature for Key3 in a unit.

@FrancesDeoliveira what is your BSA#?

Go to my.scouting.org and sign in
Click Top Left “Menu” then “My Dashboard”
Click “My Training” and choose “My Profile”

At the bottom left all your positions are listed - if you do not see “Unit Advancement Chair” then one of the Key 3 for you unit has to go to Unit Security Manager and make you UAC there

Got it. Thank you. I’ll reach out to them and get that updated. Thanks so much.

@FrancesDeoliveira I need a little more data please.

  1. When you went to Internet Advancement you saw Unit Advancement Chair there?
  2. When you went to my.scouting.org and Profile - did you see unit advancement chair there?
  3. Does your unit use Scoutbook? if so you do not need to use Internet Advancement

@MarkOwens1 or @FrancesDeoliveira - it would really help if one of you could do a 10 minute screenshare with me to see a few things to report to IT

Hi Guys- 2 questions-
I have been uploading into scout book the advancements for my troop- do I not need to upload a report from internet advancement to council for approval? How does the scout shop know what is approved that I can buy?

also I am trying to run a report through internet advancement for purchasing and for our committee meeting- It has a previous 30 days advancement report feature- which is what we need- but I am getting an error message- that it can no be uploaded-
any guidance on how to proceed please?

@Brittanystamm a few questions

  1. Are you using Scoutbook.com or Internet Advancement (scoutbook.scouting.org)?
  2. Both have an Advancement Report to take to the Scoutshop

I’m using both- I guess.
I input through scout book and need a report to take to the scoutshop- couldn’t find a report on scoutbook- so I tried to download from internet advancement.

On scout book, the report I found was for individual and has the scouts entire history- which is not what we need .