Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Error on merit badge advancement entry

Folks, I’ve been an advancement coordinator for ages… I’ve entered tons of them.
But today, it’s erroring on me like this:

Please advise. I’ve never seen scoutbook error on a merit badge like this!!!

-Phillip

2 Likes

The Unit Advancement Chair functional position in my.scouting.org (which is what is used for access permissions to the logs in IA2) has to be re-set every year by one of the unit Key 3 (SM/CC/COR) in the Organizational Security Manager under the left-side menu at my.scouting.org. The functional positions (UAC, Key 3 Delegate, etc) expire each year when the new charter is posted (not when it is submitted).

I suspect that’s what happened here, based on time-of-year. I just had to have my own K3D position re-authorized for the same reason.

1 Like

yeah, I had mine reset a few weeks ago, just after the new year.
That problem has a different symptom. With that problem the darned “internet advancement” section is just unavailable to click on.

I’ve had similar cases like this in the past, but it’s always been obvious what the problem was (like the scout already had the badge). In this case it just has “error” and I’m lost.

-P

Hrm…check the scout’s membership page in Scoutbook for a spurious membership in another unit. Sometimes that fouls things, particularly if it’s a pack membership.

I think this is probably the same issue as this other thread:

The developers were able to reproduce the error message.

They are working on a fix, but I do not have an ETA.

You should be able to use scoutbook.scouting.org to record the MB while the Internet Advancement developers are working to fix the bug. The systems write to the same database but use different methods so you should not be affected by the problem.

FWIW I receive the same error message when trying to access the 2019 Activities Calendar (not 2018 or before, not 2020 or 2021). Never had an issue before. Developers are looking into it but it’s been a week or two. I’ve also had some strange issues this week entering scouts into an Activity (it will let me add 2, but when I get to the 3rd it deletes one of the first two; the fourth deletes the 2nd, etc). I eventually worked around this by saving and going back in to the date, but I’d say IA is a bit buggy right now…

Yep, same issue on 10 merit badges trying to record. Never had an issue before.

The developers are aware of the bug. I do not have an ETA on when it might be fixed.

getting error message when i try to save merit badge completion.

image

I got the same Error message repeatedly when I tried to enter hiking and camping activities in IA in January of this year. When the error message went away the next day when I entered the activities, IA entered the activities for January 2021 okay, but they were also duplicated in January 2020.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.