Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Error when recording merit badge

When I try to record a competed merit badge for a scout and hit record and finish the system gives me an error
“Error An error occurred while processing the request”

I am the advancement chairman and now can not enter advancements

Are you trying to do this in Scoutbook (scoutbook.scouting.org) or in IA2 (advancements.scouting.org)? The permissions structures are different between the two, so that can impact the potential solutions.

I am in IA2(advancements.scouting.org)

For IA2, you have to currently be either:

  • one of Unit Key 3 (SM,CC,COR),
  • a Key 3 delegate designated in the Organizaional Security Manager at my.scouting.org by one of the Key 3, or
  • the Unit Advancement Chair designated in the OSM at my.scouting

The latter two positions “expire” when recharters are processed, so yours might have been hit by that. Mine just hit overnight on Tuesday, so I had to ask my CC to redesignate me as a K3D for my unit yesterday. If you log in to my.scouting and check under My Profile → Registrations, I think it will show up there:

Yes we ran into that issue earlier in the week and could not even get to these screens the SM re-added me as the advancement person When I look at my profile it shows me as advancement.

Well rats. Another perfectly good idea shot full of holes by the facts.

The other thing that occurs to me is that the scout might have an erroneous “current” membership in a pack, but I’m used to seeing that issue from the Scoutbook side of the house. I don’t know if that will also impact IA2.

Anybody from SUAC have any suggestions from the technical side of the house?

I can see 2 “Unit Advancement Chair” functional role entries. Both have the dates: 01/01/2021-12/31/2021. One says current, the other says not current. I am not sure what would cause the double entry with the same dates.

The scout master said he entered my position but got no feedback and could not see it changed so he entered it again just after the first time still not feedback but just waited a day and it showed up. I tried another two scouts and cannot enter merit badges for them either. I tried a rank advancement and a totin chip and they both worked

The apparent merit badge specificity really does suggest to me that it’s the “phantom pack membership” issue.

I assume you don’t generally use Scoutbook, but if you log into scoutbook.scouting.org, can you check the memberships of the scouts that you tried to see if they have a spurious pack membership? I don’t know if that’s visible to UAC or not.

It worked with these scouts in Nov for our Nov COH. One of the boys has been in the Troop for 5 years, so he has not been in scout book as a cubscout

Please post a BSA number of one or more of the Scouts and we can check.

Just the BSA ID, no names are needed.

128071641 is his BSA id number

Scout’s membership and registration both look OK.

The developers were able to reproduce the error message.

They are working on a fix, but I do not have an ETA.

You should be able to use scoutbook.scouting.org to record the MB while the Internet Advancement developers are working to fix the bug. The systems write to the same database but use different methods so you should not be affected by the problem.

I logged out of everything.
Went to scoutbook.scouting.org
Clicked internet advancement which took me to the same screens
I tried again but got the same error
Is there another way to enter merit badge completions that I have not seen?

There are a couple of ways to enter merit badges for scouts in Scoutbook.

If you only have a few to enter, and they’re all/mostly different, you can go to each scout’s advancement page from:

My Dashboard → Administration → My Units → Troop Roster → Scout’s name (right click to open in new window)

From the scout’s page, go to
Scout’s Advancement → Start another merit badge → Merit badge name → Percent completed

Enter the date the blue card was signed by the counselor and mark it Leader Approved.

If there are large groups of badges all completed at the same time (e.g. from summer camps or MB days), it may be easier to use the Quick Entry interface at:

My Dashboard → My Units → Quick Entry → Enter Merit Badges

ETA: Marking the badges Awarded will prevent them from appearing in the Needs Purchasing report and purchase orders, so avoid doing this until you’ve actually presented the badge to the scout.

Also, there is no “undo” feature for quick entry, so double and triple checking is my rule of thumb there.

I have been getting this error all week. I was able to enter merit badges earned at the end of January, but now it doesn’t work for either merit badges or rank advancements.

I am the Advancement Chair for our troop.