BOY SCOUTS OF AMERICA

Scouting Forums

Error when trying to invite Committee Chairman

My Committee Chair can’t access Scoutbook. His profile was imported via advancement sync. He is in the roster as Committee Chairman, and also as Pack Admin, and he is is marked as “pending.” In his profile, it says he has not been invited yet. When I click the “invite” envelope so that he can activate his account, I receive the error “Whoops! We encountered an error trying to process your request. Our webmaster has been notified and will fix it ASAP!” He never does receive an invite email. I first tried about a week ago, and as of today it’s still happening. I’ve tried different emails, but to no avail. I tried to delete his profile and add it from scratch, but it won’t allow me to do that with an imported profile. Any thoughts on how to fix this?

Matt - the key 3 of the unit should log in with their my.scouting login.

He did say he tried doing that already, but I’ll double check with him. Thanks!

The MYST login applies to all of the key 3. I need to ask if this is the very first time your units are using scoutbook?

If he can’t log in, have him try the forgot password link. That sometimes resets things.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.