Error You are not authorized to view the user advancement

I am advancement chair of my troop and I am not able to access few scouts accounts. I am getting the following error message:

You are not authorized to view the user advancement.

Logged-in user does not access to this API.

Please help. Thanks!

Are you looking in Scoutbook ( or IA2 ( What positions are listed in your profile in vs what’s listed in Has your charter been finalized (i.e. expiration date some time in 2022 for your unit-level positions at

Also, if you post the BSA ID numbers (no names) for you and a few of the scouts for whom you’re having access issues, that might help SUAC identify any issues.

I am looking at I can access all the scouts accounts except 2-3. I am handling this job past 6-7 months and never had this issue.

BSA ids are -

Fair enough, but when recharter season hits (for many units around the new year), many folks’ functional roles (which govern access through IA2) lapse and must be reset. That is often the issue when folks have trouble with advancement access, although generally it manifests as an issue with all access, rather than just some.

Since it’s only a few scouts, there might be an issue unique to those scouts. That’s why posting the BSA IDs may help the SUAC folks do some additional diagnosis. Some of them have greater visibility into the system than run-of-the-mill volunteers like us. :^)

1 Like

Please let me know to whom should I contact to resolve this issue. Thanks!

I was hoping one of the SUAC folks might see the post and be able to investigate. @edavignon, any of y’all around today?

I see @WilliamNelson on. Maybe he can help.

Thank you for your help.

This should be corrected now, please try again.

1 Like

Sorry but I am still not able to check these accounts. Now I am getting the following error:

You are not authorized to view the user advancement.

There are no “Approved” items to show. Once you or another unit key 3 begin approving advancements for Oishik Mukherjee they will be displayed here.

Log out, shut your browser, open your browser and log back in


The middle BSA Member ID is from Capital Areal Council. Please check to make sure it was entered correctly.

The other two have 2 entries for your unit with the same dates, one listed as current the other not. This could be confusing the system. You may need to speak to your registrar to get it corrected.

The middle BSA Member ID scout has recently moved to our troop. Also I am getting the same problem with the first one. I logged out, closed the browser and started again. I even tried on another browser but I am getting the same error. Can you please elaborate about “The other two have 2 entries for your unit with the same dates” . I am confused. I was able to check and make changes in the past with those accounts. Really appreciate your help.

This is what I see in Akela for the 1st and 3rd Member ID:

The system may be getting confused because of the entry that has Is Current No.

I found the BSA Member ID in your Council for the 2nd Scout. His Scoutbook account still had the wrong ID.

I have updated the Member ID in Scoutbook and requested both a position sync and advancement sync. The next sync is scheduled for 4:00 PM Eastern today.

This Scout has the same issue in your council as the other two. There are 2 entries in the membership table for this year.

Check after 4pm Eastern today, after the sync occurs that Ed requested, and let us know if you see any change. You still should follow up with your council no matter what.

Thanks for your reply. I am still getting the same error. I will call the local council on Monday. Is there a way to reach out to them via email.

That depends on your council. You could contact your registrar. Our council’s registrar’s email is listed on the council webpage.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.