BOY SCOUTS OF AMERICA

Scouting Forums

Extension Merit Badge Quick Entry - "Error approving Merit Badges"

Good morning, all,

I was attempting to enter multiple requirements for a scout I’m counseling for Cooking MB. I got the error message below:

I checked and none of the requirements I entered were logged.

I verified that I have a connection to the scout as an MBC for Cooking. I am also a unit administrator for the unit. Issue occurred on both Chrome & Firefox (both current versions), using v0.41.0.19 of the extension on Chrome & 0.41.0.18 on Firefox.

I did not notice any obvious javascript errors logged in the console window under Chrome.

Thoughts?

ETA: AWS server AWSWEBSCTBK2A in case it’s relevant.

are all scouts on the correct version of the MB? But I dont think that matters

Hi, Donovan,

Yes. The versions of the MB for the scouts all match (both the version I tried to enter and one another).

did you try to reenter again and did it fail again?

Try checking the Scout’s Membership page. Check to make sure that the Scout is approved and that there isn’t an active membership with a pack.

1 Like

@DonovanMcNeil: Correct. I tried twice on each browser. I also tried again with each of the scouts individually to see if I could isolate which of the two was my problem child. Same issue with both.

@JenniferOlinger Scouts are all current with the troop and have no current pack memberships listed. Also tried toggling my own admin, MBC and ASM roles. No joy.

ETA: I have successfully used the MBC quick-entry tool before, just not working today.

Charley - I know you said memberships were good. Just an odd question but have either moved patrols, leadership positions etc ? I have seen where the roster view would show the check mark, but going to the scout record would show an un-approved status under their avatar on the scout main page. I have had to approve the POR.

This appears to be an Extension issue and I have notified @GaryFeutz about it

@Stephen_Hornak I actually went in to their Memberships page and toggled the membership approvals there to be sure.

FWIW, @DonovanMcNeil and I just did a screenshare, and it looks like I can enter the data both manually (i.e. one requirement at a time) and quick-entry via the native Scoutbook interface. It’s just under the extension that it’s having heartburn.

Charley,
The error is indicating the server has returned an error.
If you look in the Network portion of the developer console (opens with a right click on the page), it will show the messages sent to the server and the responses. It is likely that one of the last messages sent had an error where the server responded with a status code other than 200.

That would be helpful to isolate the issue.

Hi, Gary,

Looks like two scripts returning status other than 200: mbc.js and analytics.js. Snapshot below.

ETA: Couple more screenshots that may help:

Thanks Charley - that code indicates the page has moved. It may be what is causing the issue - It gives me a good point to start investigating.

1 Like

@CharleyHamilton The issue should be resolved now. V0.41.0.20 was just released to fix it. Thanks for the help isolating the issue!

Thanks, Gary.

The chrome update pushed and it looks good.

The Firefox add-on is still showing as 41.0.18, despite uninstalling and reinstalling. Is that a me problem, or is that still residue from the Great Firefox Certificate Fire of 2019?

Yes - Firefox certificates are still smoldering. They have disabled updates until it gets fixed.

Excellent. Bonfires are always a good time.

I’d say this topic can be closed unless you want to keep it open until the Firefox add-on can be pushed.