One of the parents in our Cub Scout unit reached out after attempting to take Hazardous Weather training multiple times. She would progress to the last module and then when clicking on the last module it returned her to the main menu and show all items as incomplete. I see there are other reports of this in the forum but none seem to provide any resolution.

I attempted to re-take my Hazardous Weather training and found similar to be the case for me. I was able to get to 70% complete and then when the module page re-loaded all the previously completed modules were showing as incomplete. I progressed through the remaining modules in attempt to determine whether my training completion would register after completing them but it did not. On the topic badge page (see screenshot) I started at the top left and worked across to the right. Once I completed #8 in the second row is when the issue started. The leader that reported the issue was able to get to #9 before the issue happened for her. I confirmed that she is still reflected as “untrained” in Training Manager despite having completing all of the course material.

My progress on the main training page does still show that I’m at 70% complete but the course itself is not reflecting that even though I have also re-taken and completed all of the modules.

Attempted this on Safari as well as Chrome and received the same results.

Update - Thread Summary
Since others continue to come here reporting issues, I thought I’d summarize in case it is useful. This is a painfully long thread with seemingly little progress being made.

  • Course should be run on latest version of Chrome or Edge (trainings generally don’t like Safari).
  • Clear your cache prior to taking the training to ensure the browser has no remaining info from previous attempts (some “fixes” were released throughout this thread).
  • If you post in the thread that you’re also having problems, please be sure to include the following
    • Is there a particular module that you’re getting stuck on?
    • Operating System?
    • Browser?
    • Whether you cleared your cache?
    • Whether you used incognito mode (if you do you’ll be required to complete the training in one sitting).

If you complete all of the modules in the training but it is not showing as completed due to this issue, your Council may be able to record course completion. Details are unclear on this but it seems not to be reflected in my.scouting if this is done. Not sure if this is done as an in person training or some other way by Council.

@TimRodgers you may want to take a look.

I had the same problem when I attempted to complete Hazardous Weather Training on 10/1, but in my case, it showed 80% complete.

posting to keep this alive… no response

I, too, have a new Den Leader who reports this problem.

I’ve also replicated the issue.

I have already reported it (see above). But the Learn Center team is very understaffed right now, so, please have some patience.


Good Day All,

The problem I have experienced is during exercise 08 - Windstorms.

You complete the quiz.

Then for some reason the transition moves over to exercise 09 talking about Traditional Weather Signs.

You can never complete Windstorms.

Sorry to see that you are short staff with plaguing issues. Please let us know when you have fixed this.

Wood Badge participates need this class.

Yours in Scouting,

James Bullock

1 Like

A new version has been uploaded this morning which should resolve the issue - windstorm in particular.


@TimothyRogers It is still not letting me complete the Windstorms Module. It goes through it and then right into the weather signs but does not complete it to allow forward progress.

When I open up the navigator it shows that one is complete, but Hail is not for some reason.

Edit: Tried going through hail again to see if it would push through but no luck.

@JohnGeiser did you clear your browser cache or use an incognito window since it was a new load? You want to make sure you have the new content loaded.

I did not clear the cache, but it made me start the training from the beginning. I will try an incognito window.

Cleared cache and used incognito window and it does the same thing.

1 Like

@JohnGeiser let me get your Member ID you are logged in with, and someone will check in the system tomorrow to see if they can see an issue.

MI 131799776
Twenty characters

1 Like

@JohnGeiser (@+name) to start is my 20 character hack

1 Like

Ha nice I will remember that one.

1 Like

Hi I have the same issue. No matter how many times I have attempted this module, it never goes to the famed “continue” button!


I am having the same problem. I have tried clearing the browser, trying a different browser and the program highlights #8 and show’s Hail not check marked. I can only get to 90% complete. I have restarted the program 4 times.

FYI, if you complete all of your modules your council office should be able to mark your completion.