HELP!...Scoutbook Errors & Missing Training

I went and did the Youth Training update earlier today, and when I went in to my Scoutbook profile, it wasn’t listed and I’m getting a “Warning, another user is using the same e-mail address…” error. (email is

I also can’t check my profile and get a few other errors – “Error “personGUID” must be a valid GUID” and “Error “PersonGUID” is not present in the JWT Token”

My SB User ID is 1248600, and my BSA Member ID is 133805338.

Please advise.

Thank you.

@ChrisSchnabel well there are a few issues

  1. Training is not in Scoutbook, it is in = that is where you can see it.
  2. You are logging into a scoutbook account that is not your registered leadership (MBC) position - that is MID 13797096

We can clean this up some but you should be logging into Scoutbook with your user/password which is your everything before the @ in your email.

I was logging into a “” URL (saved in my browser).

So do the two accounts need to get merged?

I tried logging in to “” with “cschnabel” and my saved password and it seems to be the wrong password…and I used up one of my attempts.

You can use this BOT to reset your password - just type reset password. If you do not know security questions just say No

When I type in “”, it brings redirects me to “My Scouting”.

well yes, but MID are you signed in under?

Click here will tell you

Screen Shot 2022-09-04 at 2.35.29 PM

I’m not logged in there. I see a “Sign In”, and dropdown by a blank profile picture, but it redirects to “My Scouting


what happens when you click sign in?

It won’t take my username (cschnabel) and usual password. Says it’s wrong. When I click “Forgot Password?”, I get this screen and is doesn’t go off of it.

Try a Private/Incognito window

Can’t seem to do that in my Chrome browser on my laptop, but I was able to log in on my phone, change my password, and then log in. I do see my old Youth Training from 05/01/2021 when I log in, but not the new one (a Youth Training update) that I did earlier this morning.

As for my two different accounts, do I need to merge them? When I log onto Scoutbook for my son, I’d like it to be the “Leader” one, but I don’t want to lose access to my son’s details.

You can add the “extra” BSA ID to your my.scouting account under Manage Member ID (I think that’s the name). However, if you have two BSA IDs in the same council, they might be able to retire one that doesn’t have a registered position associated with it. Can’t recall how the system presently works in that regard.

ETA: When I added my extra number years ago, it took a day or two for all of my training to “merge” in the system.

I received this error when I tried to merge them.

Well that’s certainly new. I know folks have done that in the not too distant past (not last week, but within the last year for sure). @DonovanMcNeil? Maybe a name mismatch?

Any idea who I should contact about this to merge the IDs?

I saw an “inactive account” message at some point. Could that be the issue?

My Accounts - 133805338 (main account…keep active!)…user login is “ - 13797096…user login is “cschnabel”

Ideally, I’d like to move all of my training from the 13797096 to the 133805338 account.

Both use the same email address is “”.

That’s what I’m hoping one of the SUAC folks may be able to assist with, at least in terms of identifying what the problem may be with the Manage Member ID tool not working for you.

I believe councils can manage BSA ID within their own council, but (at least in the past) not when one is from another council. I think some SUAC folks have that level of access (or at least contact with someone with such access), but I could be wrong about that, too. :⁠^⁠)

Manage Member ID didn’t work, because BSA member number 133805338 was deleted. You need to use BSA member number 13797096. BSA member numbers can only be managed, they can no longer be merged.

You have 2 Scoutbook userIDs. I have merged them.

You also have 2 user names at my.scouting. Please log in with the one that is not an e-mail address.

1 Like

That seems to have worked and fixed my issue! I see everything together under the one login (email address). Thank you! I’ll poke around today, but it looks EXTREMELY promising.

1 Like