How to add members to a unit forum?

I set up a unit form using Internet Advancement, and I can see it, but no one else in my unit can. I have sent a link, and they get errors that it is private or not found. I have tried to invite other leaders, and they get a variety of errors. Is there a way to add members to the forum? I can see myself as the only member.

Council 205 - Pack 0308 (116794)

Is the unit forum feature still supported? I tried looking for similar topics in the forums here, but all seemed to be at least a year old and many didn’t seem to have a resolution. It looks like this would be a useful tool if working, but we can probably find a different platform if needed.

@WilliamRothwell - what was the url of the link you have sent ?

I have had two other leaders try this and got an error message that they needed to log in. They logged in and tried it, and got a message that it was private. I sent invitations, and one was able to join, but still couldn’t see it, the other got “Sorry! This invitation is intended for new users, who do not already have an existing account.”

Thanks for looking into this for us.

Bill Rothwell

@WilliamRothwell - just for information, if you go to your avitar in the forum in the top bar next to the three lines, click on the person icon, then click on summary, then expand to show the forum link then click on it what does it show as members ?

It shows me as the only member.

@WilliamRothwell - interesting as my unit forums show parents, leaders etc as listed members. I am not certain if this is a BSA issue or discourse issue but leaning towards discourse.

I suspect the code that is supposed to add and remove unit members from the group is not working. I have complained out this to BSA IT previously but have never seen a resolution. I’ll bring it up again but at this time, I suggest using a different communication method than the unit forums.

@edavignon - thank you. I do note that I have members listed who are no longer with the unit so that equates with what you stated.

That’s also the case for my unit’s forum, as well as missing folks who are new to the unit. Thanks for bringing this up, @WilliamRothwell. I hadn’t even noticed that there was an issue until I started digging trying to come up with a way to help solve your issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.