How to make a new topic

I am unable to post a new topic to the discussions forum. Is there any issue with this or is there any issue with my credentials to be able to post?

@MadhukarGundamaraju Go to Categories > then navigate to the Sub-category you want to post then . then you will see this +New Topic button


I sometimes have issues with getting the new post button to appear. Sometimes, I have to reload the page to get the new post button to appear (or for my new post window to appear, even if I already hit the button). It also only appears once you are inside of a category to which you can post.

For example, I’m not a Commissioner, so I can’t post or respond in the BSA Commissioners forum (although I’m a regular lurker there). However, if I go into Scouting Forums → Scoutbook → Scoutbook Bugs, the New Topic button pops up.

I often have to go to the category, hit new, then open an existing post and I get the new thread box. Crazy.

1 Like

Hello folks, thanks for your help. I tried the approach suggested and don’t see the + New topic being enabled.

@MadhukarGundamaraju your image

@MadhukarGundamaraju - CLICK ON THE + NEW TOPIC !!!

@MadhukarGundamaraju I see the “+ New Topic” button in the picture that you posted (right side under the green “M”).

Does it not do anything when you click on it?

Hello @JenniferOlinger, yes it does not do anything when I try to click on it.

What browser are you using?

Have tried this with Safari, Firefox and Chrome.

See @Matt.Johnson’s comments above. Sometimes, the new topic window doesn’t pop up correctly.

Yes, I followed his comments and tried that also. It still shows up in a disabled state.

My opinion is this is way more difficult than it should be!

@edavignon you have any thoughts on this?

There has always in my experience been a delay in the response of the new topic button. This is perhaps something that discourse would need to address.

1 Like

How about a category drop down box and a send button?

I don’t think it needs to be redesigned. I think it needs to just function as designed. It hasn’t.

1 Like

And it is discourse and the BSA is a client so it goes back to discourse for a fix or a best practice doc.

It NEVER does for me. I then have to click on an existing topic and then a new blank topic opens up. All browsers except in the iPhone. It never opens up.