Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Import to Internet Advancement 2.0 failed - Invalid memberID

After a COVID induced hiatus in uploading advancement data file (from Troopmaster Web 2.0), I tried importing a data file from Jan to August 2020. We had 47 Scouts with one or more items to be reported. Unfortunately, immediately after import, 43 of the 47 scouts, report an import failure:
“Invalid memberID: XXXXXXXXX” (see attached screenshot). Now before anyone even attempt to suggest that we don’t have the BSAID in our data, we do. And I’ve 100% verified they match ScoutNET records with my Council registrar.

Also, this worked perfectly at the last January 2020 upload and all prior uploads. What has broken? Any ideas on how we can provide more data for troubleshooting this? I normally don’t wit this long to update, but yeah… COVID…

1 Like

This is a partial screen shot of the 43 errors. Again, 4 of the Scouts were not reported as bad.

1 Like

I have not seen that error in a while but it kind of looks like a space before the numbers - maybe look at the TXT file?

@DonovanMcNeil
Which TXT file? the import file?
I just checked the import file generated by Troopmaster and there is no space in the numbers,
all the way down. Here is a snip of that file…

Just out of curiosity, I just attempted to upload the same identical file that worked correctly, back on January 3rd. It failed this time, with the same exact message. Clearly, it seems IA 2.0 import feature is broken.

there are nearly 1000 imports every few days - it functions - just have never seen it do that

Wasn’t there an issue at one point where opening an import file messed with the formatting somehow? I don’t recall the details because my unit just uses Scoutbook directly, but I feel like it was a 3rd-party vendor file that developed issues when opened prior to upload.

there is no issue opening a TXT file as long as you do not change it

That’s kinda what I recalled. It was opening and saving it (even with no apparent changes) was causing an issue because it messed with the formatting. Maybe I’m thinking of something else.

No, I’m fully aware of editing and saving changes. Neither file was edited, saved, or changed prior to this observation.

Can I send my file to someone for study, or testing?

You could try reporting the issue to scoutbook.support@scouting.org, but I suspect they would kick it back with “It’s a 3rd party software issue”. You might have more success talking to Troopmaster, since you’re a customer.

Are you in more than one unit? Could you have been under the wrong unit when you uploaded?

yes I did that, but got rejected… apparently now, IA2.0 reports go to myscouting@scouting.org

1 Like

Ah. Learned something new today. Thanks, @GanttEdmiston.

1 Like

RESOLVED: Later last night, I ran the Troopmaster report again and generated a replacement advancement import file. Then I diff’ed it against the one giving the error. They were identical. I then did a chksum on both, those were identical. However, when I ran the import, it uploaded with ZERO errors. This morning the update had completed. Because I had also tried the file I used back in January 2020, and it failed, I suspect there was some brief outage at the time I was attempting the upload. Problem has disappeared.

1 Like

So did I. But guess what… not for long! Effective September 1,2020 - The national support desk will be closing permanently for all volunteers. You will need to reach out to your Council for assistance. The Council professionals will be the only people allowed to request help from national help desk.
SMH…

Is there a difference between member care in scout book support at the national office? It seems there are two different email addresses and one applies more to My.Scouting Tools and the other to ScoutBook. If that is the case perhaps we still retain ScoutBook support from national.

I wonder how that is going to effect technical trouble reports.

If a council service center is closed by the government this may mean zero support due to COVID-19.

The entire transition to Internet Advancement 2.0 has been horrible for users. Trying to enter information into a system that is so difficult and not user-friendly was not designed for volunteers whatsoever.

Whoever dreamed up the idea had no concept of user participation. And now National is shutting down the support desk and having Councils handle it. Who at Council understands a system that has failed so terribly.