Internet Advancement "Advancement History" report broken

To reproduce this issue, Go here: and login.
Select Unit, Select Unit Type, Enter unit 4-digit number, Select boy or girl unit,
Now, you previously could select a single Scout, by checking the square box next to their name, then choosing Run Report drop down menu, and select Advancement History. This is supposed to list only the single Scout.

Recently something broke and, this now outputs the entire unit, meaning every Scout. It ignores that you selected a single Scout. Please fix this.

It also doesn’t work properly for me as well. The drop down report menu even says “for selected people”.

@GanttEdmiston check this again please

@DonovanMcNeil It is almost kinda fixed. When I repeat the steps I originally outlined, the resultant report does produce a screen result of the single Scout selected. Which “technically” fixes the issue.

However, there are two buttons, “Run” and “PDF” - If I click the PDF button, I get another file, with the entire unit of Scouts again. So either it’s still broken, or I do not understand what the PDF button is for. And the “Run” button, I don’t understand why that is there at all.

With the exception of these new Run and PDF buttons, I suspect the behavior is back to where is use to be. My work around to save the report in PDF format, is to do “Ctrl-P” (chrome print) and I am then prompted where I can choose to “Save as PDF”, so I get my desired PDF file, with the single selected Scout.

I would hope someone would continue to research why the PDF button does not work, or why the PDF button changes back to the entire unit, not just the selected Scout.

However, I am back in business, as long as it doesn’t degrade again. Thank you so much for your help. If more changes are made, I am happy to test again.

I tested in Chrome, both with and without Chrome Incognito mode.


The PDF button is supposed to generate a PDF with the same data as RUN so there is still an issue.

1 Like

I have reported the PDF issue.

Thank you so much. Just out of curiosity, what is the purpose of the RUN button?

RUN displays the results in the browser window. PDF produces a pdf suitable for printing.

Well in this case, I clicked RUN, and it changed from the single selected Scout, to the entire unit of Scouts, in the browser window.

@GanttEdmiston How do you use the “Advancement History” report?

I use this report to verify ranks and awards match my local records. Usually when Scout is preparing their paperwork for Eagle, Quartermaster awards. I always click “All Dates” so that I assure that I get a single Scout’s data for their entire tenure in Scouting. Until just the last few days, this has worked for quite some time.

I noticed it “broke” about the time the header name changed to “Scoutbook Plus Internet Advancement”. I assume the efforts to migrate from Scoutbook to IA, caused this behavior.

@GanttEdmiston Have you also tried the Scouts BSA History Report and the Cub Scout History Report? They have more data, including leadership positions and dates.

@JenniferOlinger I have not tried those, but I will, thank you so much

1 Like

@JenniferOlinger Well, running that report breaks badly, see my attachments

@GanttEdmiston Do you have your COR position selected? Or some other role?

@JenniferOlinger I do not understand your question - I am a COR, but what position selection are referencing.

In the upper right corner, you should see Currently viewing: and then your troop (or other unit). When you click on the unit, does it have your COR position selected?

1 Like

@JenniferOlinger More questions: I have many registered and functional positions. I am one of three Scoutbook Council Admins. I am a COR for a Troop, Pack, and Crew, and I am also registered as a Committee Member in the same Troop, Pack, and Crew. My primary paid position is COR for my Troop.
See the attached screen shots

When I click the upper right, I can click my Troop COR role, and my Pack COR role, but there is no Crew COR role, instead it shows Crew Committee role and a message there are 3 additional roles, which I cannot see and therefore cannot select.

The results of running the detailed history report sometimes works, and sometimes fails, it seems to be related to my selected role.

Am I supposed to be able to view and select ALL my roles? Because I cannot do so.

Also, a year back, someone pointed me at a table of permissions for Scoutbook and Internet Advancement. I cannot find that anymore. Does a current version exist. Sure would help to sort out if I’m hitting an access issue, or not.

Finally, in my Council, we are just finishing up on Renewal/Recharter and my registrations were just reposted within the last 36 hours, so I know just enough to suspect maybe something hasn’t synced.