Internet Advancement Not Loading

I am unable to access Internet Advancement. Is anyone else having problems getting the program to open today?

Is there a better way to check the status of internet advancement? I hate to just post on this forum. Seems like BSA would have a mechanism for me to report a problem or at least have a mechanism so that I could check if the system is down.


loaded fine for me @UC71

I haven’t had any issues, either, @UC71.

Are you getting a 404 error, or is it loading the webpage, but not allowing you to log in?

It worked until this afternoon, but now I just get this on computer. Profile won’t load on my iPhone either.

Hrm…I assume you’ve already tried the “reboot it” equivalent of opening a private browsing/incognito window and tried logging in separately? Sometimes my browser ends up with some sort of glitch that prevents it from connecting to things. Trying the incognito/private window trick usually tells me if that’s the issue. If you have browser extensions disabled for incognito/private browser windows, it can also help diagnose that issue.

I’ll be honest. You said several things with which I am unfamiliar.

I assume, however, that if it were a browser issue, the problem would isolated to the device I am using. I also have the same problem when I try logging in using Safari on my phone.

I have zero problem getting in to Scoutbook though.

I am going to take it as evidence that I need to stop thinking about it tonight. I’ll try again another day.

I tend to agree that using different browsers suggests that it’s some other problem, but sometimes I’ve had things break for no good reason that started working when I tried an incognito/private window (Ctrl+Shift+P in Firefox or Ctrl+Shift+N in Chrome). I’m afraid I’m not an iPerson, so my Apple skills are…poor. :grin:

Good luck with the “sleep on it” solution. That sometimes works for me, too.

Sounds like at least one other person is having trouble. She works at our local Council. So, maybe it is a problem with IA 2.0

@UC71 - I just loaded IA on my phone on mobile 4g connect.

@UC71 - and tech tip… you should use snipping tool on windows machines or the screen grab function on MacOS to post what you are looking at.

@UC71 - and on my win10 pc at home load time was the same at 10.2356 seconds…

Just a reminder for all forum users. Vision impaired users who use text readers may not be able to read the text in an image. So consider who you want to read your post. If your intended audience is the SUAC team, is is probably OK to post an image.

Or for any other time one wants to convey the details or issue with the visual interface.

My point was that actual screen capture is far easier to read and understand than a photo of the monitor. I trust that is what I conveyed.

1 Like

I was entering items this morning and it was fine. Logged in to continue and it kept giving me error messages when I tried to save activities I was entering and when I tried to approve other items that were entered. My guess is it is on their end.