Internet advancements reports help

I’m an ASM in the troop and previously had no problem running the “activities summary report” from the roster, but I’m not able to do it anymore. I have no trouble running other reports from the roster. It is also strange because we have access to all the activity info in each scouts profile.

Can anyone help me figure out why I can’t run this one report?
Note: I have tried deleting cookies, using a different browser, etc…nothing seems to fix.


@RichardFriesner - when you are in internet advancement what is the program icon in the upper right showing…

That could be the key… possibly. You could also post your BSA ID so it can be investigated on the back-end

@Stephen_Hornak I’m using the correct view Troop ASM…weird ID: 12325971


Not the cause of this issue, but I believe I found a 2nd Scoutbook account for you. Did you earn Eagle in Great Southwest Council?

Yes I did. Not sure how I can have two accounts. I am registered in the OA lodge there currently.

Every time you move to a new Council you get a new BSA Member ID. Because you were registered with your middle initial when you received your Eagle and middle name now, the system did not match the accounts so it generated a 2nd SB account. I’ll merge them so you only have 1.

Your SB accounts are merged. I added your other BSA Member IDs to your ID as secondary.

1 Like

@Stephen_Hornak thanks for investigating as you have time available.

Still not able to access the activities report…not sure why. Can anyone assist?