Invitation Manager Stiil not working 8-14-2023

I am still getting the never ending spinning wheel for the Invitation Manager and a “System Error” message pop up at the District level. When I go to individual unit pages, it seems to work. This has been happening for about a week.

Similar problem to this: Invitation Manager 8/6/23


Try holding the shift key and clicking the browser refresh button when you see the spinner. This forces a reload and I have found often resolves the spinner in

Tried that, no change. This is happening on multiple PCs and my phone. I’ve tried multiple browsers and incognito mode. I can open the “Leads in Progress” report and see which units have leads and go directly to those units, so this isn’t stopping me from working (yet).

@RonaldBlaisdell FYI…

I did notice that yesterday, but not having any leads I just let it go, but it does present the red box system error msg.

I saw on social media that others were having this problem as well.

@RobertBrodner - What Council / District role are you registered as, and in what Council, please.

ADC. Circle Ten Council, Iron Horse District.

@RobertBrodner, thanks - I have validated the issue, and I have sent it off to the BSA IT team for further investigation.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.