Is Scoutbook server down?

Or is it just my connection? It loaded and I logged in just fine last night.

If it’s a larger issue has anyone heard an estimate on when it will be back in operation?

@JimDreyer loaded fine for me


Did I miss a memo on the address change?
My bookmark to worked fine last night.


@JimDreyer - that changed to a while ago

I suspect the redirect expired

The redirect worked for me, but yes, you missed the memo.

I just tried and it did lead me to the correct url of @JimDreyer I would suggest getting rid of as a favorite and any cache/cookie objects.

@JimDreyer - here is the announcement:

It was a little slow today. Had to redo my shortcut on my phone today. It was not working even though I had the correct URL.

It looks like their re-directing broke a couple days ago so or are broken and do not correctly re-direct to

The correct URL for Scoutbook is It has been this way since 2020. IT is investigating why the redirect stopped working, but we recommend changing all bookmarks to use the correct URL.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.