Issue with Setting Date - Default to today

Today when I was entering calendar events the menu allowed selection of the correct date, but when I saved, the start date always defaulted to today’s date (16 Jan). This happened 4 out of 4 times.


I tested this and the date always saved to what I selected. Even selecting the date picker on an existing event did not change the date.

If you click a date square in the future it defaults to todays date - if you do not notice and change - is that the issue?


Only on a NEW calendar entry. On an existing entry, clicking the date picker uses the existing date for that field as the default.

If I enter a new event and use the date picker it will change back to today’s date when I select “Create event”. Sometimes I get a “Error Bad Request” message or it auto saves to today’s date

I see this same behavior:

I tried again today and still see the same issue.
On the calendar view, click on a date in the future to create a new event. Here I used February 5th:

The event creation page shows the correct picked date. However, internally, it is incorrectly using today’s date for the start date.

The first clue it is uisng the wrong start date is that if you try to create a reminder for 8 hours before the event, there is a warning that the reminder would be sent in the past on today’s date:

The drop down at the top shows the correct date, but that’s not the date it actually uses when it creates the event as you can see in my linked discussion topic.

You can go back up and try to choose the correct date in the drop down, but it doesn’t change whatever internal date the create event page is using.

I did find a workaround that you can choose a different date in the date picker and then set it back to the correct start date.

That cleared the warning message on the reminder:

I have the same error - it doesn’t matter if I select the “+” to add a new item or double-click the date box. It is an ongoing problem - making it extremely difficult to use.

I am using the Chrome browser [if it matters].

This is in the backlog but not seen as a critical error, just a usability issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.