Lost ScoutNet Access due to Pulse problem

I know this is not exactly on topic, but I cannot find a better category.

Pulse Secure was updated a couple of days ago. I was able to use it to get into ScoutNet yesterday. This morning, I tried, and it asked to install a new Pulse Client. I did this, but now everytime I try to connect thru pulse, IE says "Failed to download app, Pulse Secure Client Setup.
It offers to run Pulse Secure Setup Applet, which I accept and run.
But when the process completes, I still get the failed to download app again.

Please tell Tech Support that the Pulse update lastnight has problems!

@GregoryBuchanan - not sure if this is applicable but there is a community for pulse

Thanks for the feedbak Stephen. Unfortunately, that is not the problem I am having. BSA did an “emergency” install of updated Pulse Secure due to a security exploit found in the older version. Yesterday, after the initial update on the BSA server, I was able to login successfully. But when I tried this morning, it won’t load successfully.

Has anyone been successful in getting remote access to ScoutNet using Chrome browser? I have been on Internet Explorer because it was the only one that still accepted Java code. I tried to access ScoutNet with Chrome. I can get into the web site, but am unable to get it to launch the ScoutNet program for access to the DB. I think that still needs/uses Java?


I thought ONLY IE6 or something like that worked with SN?

It probably works with newer IE, but it is definitely a Java applet which isn’t supported in newer browsers, so it’s IE or maybe older versions of Firefox or Mozilla might work. I don’t think Chrome ever had Java support available. The Java would need to be Java 8 or older. They removed applet support after that. I have no idea about BSA’s IT setup and the degree of need for any VPN or the configuration of said VPN.

@brantgurga - oh I had not thought about java as a possible tie-in. There are methods to establish exception on java execution.

My media distribution system needs to run java so we retained an older IE version on our admin portal just for this auspicious occasion of me configuring media endpoints and encoders.

Thanks for the ideas. I was aware of the Java problems. I have used IE to access the Program part of ScoutNet for years. I was online with it yesterday. Last night BSA Support installed a new version of Pulse Secure and suddenly my I can no longer get the program screen to come up. When I try to login to ScoutNet, I get “Failed to download the application” error, followed by a second “Failed to download the application” errof (for Java, I think). Then it offers to run PSSetupClientInstaller.exe. I tried that, but to no avail. I have tried uninstalling all Pulse software and letting it install new versions, but no joy.

@GregoryBuchanan - no problem… having to deal with remote internal and external clients. I am bound and deteremined to make stuff work…

Here is something else that may or may not be related… but this is seeming like something not unknown.


Thanks Stephen, but that is not it. What is the “preferred” browser for use with ScoutNet remote? I have been using IE because it still supports Java, and I think the Program function in ScoutNet requires Java. Is there a better browser that supports Java than IE. Chrome, my main browser, does not.

I have tried to access the site with both IE and Chrome. Both eventually let me access MyBSA site and I can launch My BSA ScoutNet. But when I select ScoutNet Menu item Program. it displays “Loading program form…” and hangs there. I think this is because Pulse has not launched correctly. Since it all worked yesterday, and I didn’t change or install anything since then, I am convinced it has something to do with the Pulse critical update installed last night. How do we make BSA Support aware of that issue?


I’m tagging @RickHillenbrand. He usually has good visibility into the technical side of the house.

I have to punt on this … but will make sure folks in IDG (BSA IT) are aware.

Thanks for your help. I can provide more information if they need it.

Have a good weekend.

So here is the way to move this issue forward: this is going to require the individual(s) with the issue to go through their local council to have a MemberCare ticket generated. Sorry I was not able to get an answer that would provide a less labor intensive effort, but this is the best that can be offered up.


Thanks for your help. When I tried again today (Monday), it automatically downloaded a new version of Pulse Secure and it all seems to be workin now. I assume they made some fixes over the weekend or Monday morning. The Flash Page for MyBSA ScoutNET doesn’t mention any changes, but it is working for me now.

Appreciate your help.


Oh-kaaaayyyy… “magic” :wink:

1 Like

@RickHillenbrand -generally it is magic… at least in my experience of supporting end users… :slight_smile:

1 Like

When I encounter magic situation I often say it isn’t fair. When something is broken, it isn’t fair when it starts to work with no clear resolution. I don’t like magic! If it fixes via magic, it could break again via magic.


@Matt.Johnson - you are right there… The funny thing is at work they call me the Doctor… as in the time lord since the issues will often correct themselves before I get there with the magic screwdriver…


To be totally up front… most of us experience those huge… painful moments where you just dont understand why this is not working… and a good break from it, nice cup of tea… perhaps a glazed dougnut or a walk or talk to the dog will often help…

1 Like

@Matt.Johnson @GregoryBuchanan I appreciate your understanding how I feel, and this exchange has put a smile on my face.